Hi all!

I have a PO-12 and PO-28 that I sync with an Arturia Keystep. My PO-12 syncs perfectly every time and stays on beat regardless of where it is in the chain. My PO-28 drifts after about the 4th loop. I took some time this morning to try and isolate the problem. I connected it in various sync modes, and it seems that the PO-28 gets off by half of a step after being in sync for four steps regardless of whether the clock signal is coming from my volca keys, arturia keystep, or the PO-12.

Is there some secret setting that I have turned on that's causing this to happen? I've tried taking out the batteries and I've also tried different kinds of batteries. Or is my PO-28 just faulty?

Maybe you need the sync signal to be louder

PO has more stricter demand on the sync signals.

Thus, you need a hotter clock signal.


Same problem here with the Keystep and POs 20/24/28. My 12/14/16 work fine though. This is the first I’ve seen of this problem and so haven’t had time to test things.

I did however try a Volca Sample between the Keystep and the POs using the Sync In/Out on the Volca and that works flawlessly (at least for now). Like the previous posts say, the new POs might need a hotter signal than the Keystep puts out.

I’ll post here again if I come up with something useful.

I have exactly the same problem. Did you find the solution?