PO-28 Robot not recording FX#13 exactly as you punch them in?

Hi guys,

I recently bought Arcade, Office and Robot. While waiting for the next salary to buy proper drum machine a.k.a. Rhythm I was jamming with the Robot micro drum set today and noticed quite a weird thing.

Long description (TL;DR skip to next paragraph):
I layed down basic “drum and bass” pattern (kick, hat, snare, hat ; hat, kick, snare, hat ; x2) and started jamming with FX, mainly FX#13 - Glitch. When I triggered it at the very first hat at the 2nd step, it never starts the recording there! Instead next time the effect starts right on the first kick. Similarly, when triggered on the first snare (3rd step), the recorded effects then starts with the first hat (2nd step). When you try for example second snare on step 7, recorded fx starts with kick at step 6. My swing is set to 0 btw… Seriously, what the f**k :open_mouth: It kinda ruins the effect for me :frowning:

Short version:
FX 13 - Glitch doesn’t record properly, it looks like the recorded effect starts at the step before the one where you actually started recording it. Hear it yourself in the following short video demonstration (and please bear it was a real quick recording so please don’t mind it’s only in one channel and there’s also some weird background noise).

Video goes here: 2017-11-06 23-24-52.mp4 - Google Drive

Could you perhaps try to replicate this behaviour on your Robot for me? I’m really curious why is that happening…


I just made two simple patterns and chained them, then tried punching in various effects (starting with #13) and it works as expected.

I couldn’t replicate the behavior on your unit. Does this happen using other effects?

Guess I described my problem in a bit misleading way, sorry for the confusion (I mistyped “pattern” where should be “step” one time, corrected that already). It looks like it’s a common bug of a Robot device, someone on Reddit tested it for me and got the same result.

Here goes the reddit thread, interesting read btw: https://www.reddit.com/r/pocketoperators/comments/7b8w8h/po28_robot_not_recording_fx13_exactly_as_you/?st=ja0sgvnk&sh=170f906c

Yeah seems PO-28 has some software bugs. Recently I also discovered one affecting the drum machine sound “SE4”. For all drum machine sounds, knob B controls the release rate (length) of the note, except for SE4 which has a fixed length but knob B adjusts the pitch. Seems that this exception was not implemented perfectly. At some cases (not fully analyzed when) at write mode and play, SE4 steps tend to shorten so bad they almost sound like a click. After doing some apparently irrelevant stuff eg. exit/enter write mode, change sound (also not fully analyzed :slight_smile: ) the issue heals.

Sorry if this was OFF topic here…