Pocket operator 133 doesn't preview all drum set of button 16


I just received my PO 133, and the preview sounds from drum set button 16 doesn’t work as expected, when I’m pressing sound + drum set, only the first one sample works, while I’m holding sound button and press button 16 only play first one, is this normal? All other drum sets repeat as normal and iterate the 16 slices, except sound 16.

Here is a video:


1 Like

Have you tried tweaking the 2 knobs?
I don’t remember how track 16 is behaving on 133, but on early series you had to choose the sound for track 16 with a knob.

The knobs only change the pitch and volume on my unit, it seems like a firmware bug to me, the unit works as expected except for this bug, but it could also be a weird hardware problem.

I don’t see the problem in your video.
Would you mind trying to rephrase what it it that you see as a bug exactly?

When you hold down the sound button and press a drum set button (9-16), the PO plays a preview of the drum set sounds, each time you press it plays a different slice on the drum set, in the video you can see that I hold down the sound button and then I press button 15 on the drum set, and the sound changes every time I press that button, with button 16 only the first of the 16 slices in this drum set is played (the hadouken sample), that’s the problem, my PO 33 works as expected with button 16, but not my PO 133.

1 Like

I’m not familiar with P-33, but if you own both I guess you’re the expert there ^^
Well, keep us posted once you received an answer from TE!

Thanks anyway, if anyone has a PO 133 and can test if drum set button 16 has the same problem as mine I’d appreciate it.

Mine works just fine!

Could you check what release the firmware of your po 133 has?
Holding Sound button and pressing bpm several times shows information about the device, battery, cpu… there is one called rel (release), it is the firmware version, mine is version 50, what number does it show when the word rel appears ?

1 Like

Hi, sorry for the late replay. I just checked again and indeed with slot 16 it is not working. I’m on 50 too. Do we need to contact TE about this issue or is this normal? My 33 KO doesn’t have it, that one is functioning well

I made a case at TE today. Will let you know when i have more info :slight_smile:

1 Like

Great, it seems to me that it could be a firmware bug, I probably also have to contact TE, my PO33 does not send the sync signal if a pattern is empty, and this bug is fixed in PO 133.


No word from TE yet :(.

I guess a minor bug in the firmware is not a high priority, I hope we hear something from TE sooner or later.

1 Like

Replay from TE:

hey Arne,

having spoken to our developers, it seems that this is deliberate, as with the default sounds it plays the word “Hadoken” when pressed which is one of the best known sounds from the franchise :slight_smile:

if you have any other questions please do not hesitate to ask, we would be happy to help.

have a wonderful week!


So it’s a special feature of PO-133, mystery solved!


Yep, I guess so :slight_smile: