Sampler on Synth Tracks with long decay (what am I missing?)

Hi I’m playing with the new sampler stuff and I want to take a sample on one of the synth tracks and give it a long decay (release) with the envelope. So I’ve set the loop points inside the main start and when I’m in sampling mode, when I hold a key down, it loops like I expect it to and even has a nice decay after I release.

But once I leave sampler mode, as soon as I release a key, the sound cuts. I’ve made the release part of the envelope as long as it goes and I can’t hear it ringing out at all.

Is this a bug or am I missing something critical in the process?

How about setting the note length longer?

Have you selected the track button and scrolled/ selected 3? This firmware update defaults to 1 which is a short release. 3 should let the key release like normal.

I’m playing them on the keyboard manually at the moment, but I don’t think note length should matter because the release stage of the envelope comes after the note stops playing.

Sorry… not sure what you mean. Scrolled/selected where?

Note from the firmware update page:

this firmware adds support for the gain, play direction and playmode settings of the OP-1 sample format. in older firmwares, these settings were ignored. this might lead to your patterns sounding different if you are using custom samplepacks.
the most likely culprit will be the playmode setting. the OP-1 defaults to GATE, while the OP-Z used to treat everything as RETRIG. Adjust your playmode setting on each sample to RETRIG, to get it sounding like before.

if your track levels change due to the gain setting, either adjust the track volume, or adjust the per sample gain value.


Hold track button and scroll green disc until the number key shows 3

Sorry I still don’t know what you mean. If i’m in sampling mode, the track key turns on the reference pitch and if i hold the track key and turn the green dial, it adjusts the volume of the reference pitch.

If I’m out of sampling mode, just on the track, holding the track button lets me choose other plugs. The 3 key there is one of the synths in this case. Spinning the green dial while holding the track key here adjusts note length, but like I said, this isn’t about note length… its about the release of the envelope after the note stops.

Am I misunderstanding you?

Doesn’t this only relate to drum samplers? The synth sampler doesn’t have a playmode setting (the little red icon that you see in drum sampler mode isn’t there in the synth sampler mode). Setting the loop points inside the waveform seems to change the behaviour of playback when a note gets held, but I’m still not getting the release stage of the envelope.

I have the same issue here. Created a sample on the Arp track, set the attack and release parameters pretty short, activated the drone mode (press “Track” and Scroll the green Wheel completely up so the white LED lids up - this sets the note length to “endless”). No success, the note is being retriggered each time the pattern gets repeated. I set the note length manually over the whole bar, no success. I edited the loop points in the sample mode. No success. I also tried the above mentioned trick and changed the note style to legato (this was the most obvious point to start to me). No sucess. I think it’s a bug. I will ask the guys at TE if there’s a solution for it.

Are you extending your note by either holding key during recording, or post recording selecting the note and extending it to additional steps to stretch out your envelope to allow the sample to decay using the envelope setting? I haven’t dug as deep into synth sample tracks, but these are the first things to check off the list post OS change.

I’m playing the note live on the keyboard. I understand that you’re trying to help, but if you yourself haven’t yet made a sample synth that has a release stage on the envelope and looping points set inside the sample range, I don’t think you can actually help me. It seems to be a bug in the firmware.

On my op z i can hear the release. Shift for second parameter screen dont make a short loop And you Will hear your envelop attack And release .

The second parameter screen of sampler mode? Yea, I hear the decaying release stage on an envelope in sampler mode, but when I switch out of it (back to the track for sequencing), I can no longer hear it.

Also the release that I hear in sampler mode doesn’t correspond to the envelope set on the track. I tried removing the release and in sampler mode I can still hear it.

Over here it really works. Outside sample mode as well.
Maybe try a reinstall?

Sorry for not fully comprehending the issue last night.
Didn’t mean to throw you for a loop :grin:

After following OPs synth sample example, I can hear both looping points when key is held, and the decay/release stage follows where I set it for both single trig input or releasing out of the loop when held. While your holding the trig and the loop is cycling, you have to release the trig to hear your release adjustments.


I solved my problems exactly this way! Thanks :slight_smile: