Hello everyone…question…I have a MacBook M2 with Sonoma and ableton does not detect the audio channel when I put my op1 in USB audio mode…will I have to wait for an update? greetings

1 Like

First off, lemme say that my message is guesses and hints. Your system has its own setup, so it could be one of various issues.

That being said.
Sonoma is a brand new OS, and loads of softwares are yet to be confirmed/updated to be working with Sonoma’s architecture.
So, it could be Ableton, it could be Sonoma, it could be the OP1, it could be any combination of these three.

You’d have to investigate with other gears and/or other softwares in order to track down the culprit.

And if any fix is not on the table rn, you should still be able to downgrade. Not for long, but still.
If it’s a brand new machine, this should be a bit of a hassle. But with a Time Machine from your previous OS, it should be easy af.

Please, keep us posted. This could help others down the road !

1 Like

Thanks Heyes msybe ableton is the problem yes you are right thanks.

1 Like

If I remember, I can try this later today. I’ve got a MacBook Air M2 running Sonoma as well. Just need to dig out the OP-1 — it’s been set aside in favor of the OP-1F.

1 Like

Yes I have to connect op1 to digitakt IN and send digitakt to ableton in audio usb mode…ableton detect digitakt usb audio no problem…

So, I just tested using Sonoma & Ableton Live 11. It works. I chose the OP-1 as the inputt device and the MBA speakers as the output device. Ableton didn’t complain. Then I chose EXT 1/2 for the input on an audio track, and to verify audio I set the monitor mode to IN, so I could hear what was coming in over the USB connection. (This is using a direct USB-C to USB-Mini-B cable).

I don’t know if it matters, but I have Ableton Live as one of the items allowed to use my microphone, too. I don’t know if that only applies to the internal microphone or all audio inputs…

Do you see the OP-1 as an audio device in Ableton? If you don’t, you might want to check any cables, adapters, or a hub if you’ve got one inline.

Hope that helps!


Hello, thank you for responding…I solved it…in macbook preferences, accesses I activated the microphone, now it works perfectly and ableton plays the op-1 usb audio mode…thanks a lot friends

1 Like