Still cant connect nanokey studio to Op-Z

Hi everyone. I scoured the forums looking for a solution but haven’t found one yet. I’m trying to connect the op-z to the nanokey studio directly with a wire. I see a quick light up on the keyboard after connecting the two devices and then nothing. The nanokey works if using a powered usb hub and using midifire but no direct connect. Has anyone got this to work? Thank you!!

Better late than never? I just got my second nanoKey Studio after the first went missing, and it is having the same issue you describe. I figured out this process to make it work direct, though:

Troubleshooting tip for Korg nanoKey Studio w/ OP-Z:

Problem: nanoKey boots briefly when plugged into OP-Z USB, top 4 pads flash white, then all lights go off, & unresponsive.

Culprit: not enough power for bootup, probably

Setup: OP-Z will need USB-C OTG cable (female host), then standard USB to micro USB cable into the nanoKey (don’t plug in yet) (some users say a direct C-to-micro works, but I don’t have one to test)


  1. Turn on OP-Z.

  2. Turn on nanoKey on battery first, blue light flashes

  3. Plug in cables

  4. Then quickly slide switch over to USB power. nanoKey Studio will power cycle in the normal way and should now work.

Also, try making the settings in KorgKontrol application for USB all to lowest power possible

Also try: a powered USB hub will provide enough power for the Korg, but not using it is slicker & portable.

Also, I am using Cable Creation brand, fwiw.

I had a nanoKey Studio a couple years ago and it used to work a lot more seamlessly. Then it got stolen and I just now got a new one… had to try just about every cable and order of operations, and this is the only one that worked… but now it works great! Yeay portable velocity sensitivity and true triplets.

This poster had it working:

I just got a nanokey studio and it works just fine with my OP-Z, both directly through a usb-c to micro usb cable (Amazon basics) or through a powered hub. I haven’t tried wireless.

Perhaps issues were fixed in updates either on the teenage engineering or Korg side?

My only gripe/bug is that assigning filter (cc 3) on track 1 to knob 1 on the nanokey studio seems to affect the filter on multiple tracks. Midi monitor shows that it is transmitting the correct messages, so I guess something on the OP-Z side. Something to test more, perhaps just a glitch.

Otherwise, I’m really impressed with nanokey studio and looks great for performing with OP-Z!