Syncing pocket operator to OP-Z with line module

Hello everyone!

It’s seems like such a simple connection but I can’t seem to get it to work (or maybe I just don’t get it). Basically I am trying to sync the pocket operator to the OP-Z via the line module so I can hear both the po audio and OP-Z audio come thing through the OP-Z. So far I am able to start and stop the pocket operator by pressing play and pause on the OP-Z but that is about it. The po audio comes out of the po and the OP-Z audio comes out of the OP-Z. However, the moment I try to connect the output of the pocket operator back into the line in module (left most hole) I am still able to control the po start and stop but there is no po audio anywhere. The line module is clearly indicating signal but I have tried turning absolutely everything up without any success. I think I just don’t get the I/o page on the OP-Z to be honest. Also my selected midi settings are 3 and 5 on the OP-Z. The highlight when holding shift. That has been the only configuration that allows me to start and stop the po. What am I missing?

Also just for the sake of saving peoples time I have the line module set to PO and midi (although I have also tried trig and got no difference) and I have my po in sync mode 2 (have also tried sync 3) I am wondering if the issue is that I have not properly set up the I/o track in terms of where it is sending? Although that is also something I don’t entirely understand at the moment. Just trying to give some context. Any help would be much appreciated!!

From your description, you’re doing everything right but there are a few more settings that could be your issue. Quick side note first: you don’t actually need any MIDI settings enabled for the line module to send PO Sync.

Alright, onto the troubleshooting:

  • When you hit shift on the I/O track and press 4, does the 4 key’s light turn on/off? It needs to be on to hear the line module input, and if it responds it at least tells you the OP-Z is detecting the audio from the module.
  • Is the master send on the I/O track too quiet? This is controlled by the red encoder on the fourth parameter page.
  • On that same parameter page, are the green and/or blue encoders really bright? Asking because, if the I/O track is only sending to FX1/FX2 this could dampen the sound.
  • It could be worth hitting Track while on the I/O track, selecting plug 1 and preset F1. Assuming you haven’t changed that preset, it will restore the default settings for that track which can rule out things like the filter, etc.
  • When I plug anything into the output of a pocket operator, it drops the volume automatically. Have you tried turning it back up? (BPM + sequencer key)

Hope this helps, and good luck. I’ve had plenty of success with the exact setup you’re describing so it is possible!

1 Like

Thank you for the reply!

I ran through the list and unfortunately no difference. My volume is maxed on both the fourth parameter and the pocket operator. I am able to turn 4 on and off but that also makes no difference. I noticed that the 4 does not automatically turn on when I plug the pocket operator in so maybe there is an issue there. Also if I do not have 3 or 5 on then I am completely unable to control the start and stop of the pocket operator. I have the right most hole of the line module going into the input of the po and the left most hole of the module going into the output of the po. Something else I noticed when watching tutorials is that people have the 0 on when they hold shit of the module track and I am unable to turn both the 9 or the 0 on when i hold shift on that page. I don’t know if any of this info may reveal what the issue is but I am trying everything. At this point I am slightly nervous that my line module is faulty.

Thanks for the quick follow-up!

Are you using the most recent firmware, 1.2.45 (download & instructions here)? If you’re not sure, the Devices screen on the app should tell you.

I’m asking because my I/O track doesn’t show MIDI settings even when I disable legacy input select and remove my line module, but the behaviors you’re describing are mentioned in an older version of the OP-Z manual I found on these boards.

I think it would be especially disorienting if you’re expecting I/O settings but the OP-Z is showing you MIDI settings, since MIDI settings are 1-8 while inputs are 1-4 and 0 (to monitor input).

I’m hoping it’s that simple but just in case it’s not, I’m curious: have you been able to hear audio from anything else you’ve connected to the line in?

The update solved the issue! I had recently purchased the device so I assumed it would arrive with the latest firmware. Clearly i forgot that it was teenage engineering we were dealing with haha. Nonetheless thanks so much for the help. All set now! :slight_smile:

1 Like

Honestly, plenty of manufacturers don’t update their hardware to the latest firmware for various reasons, and instead leave it to the user to do.

Once they have a consistent process to manufacture the hardware, it’s typically easiest for them to use a specific version of hardware, so they can run any dead on arrival or other basic tests just to make sure it works. To update the firmware to a new version could potentially require a requalification of the whole test harness and setup.

Typically you’ll see the updates happen when there is a hardware change (ie new parts/components) that requires new firmware to work… then they will invest in updating that testing harness. Presumably that hasn’t happened yet, so TE just hasn’t bothered to do the updates themselves as part of manufacturing.

The dig may have been a slight attempt at trying to cover my own butt for not thinking to update the damn thing. We may never know :eyes: