Tape track from computer to OP-1?

Hello. I just tried to back up the files on my OP-1 to Macbook Air. Moved the album tracks, and the four tape tracks to a folder on my desktop. Clicked eject on the disk, and the OP started running command lines or whatever on the screen than froze.

Turned the OP-1 back on, and the four track was empty. Went into Disk mode again, and moved the tape tracks from the folder on the desktop back to OP-1. But still, no tape tracks appear on the tape.

My questions… what happened with the initial OP-1 crash when ejecting, is this a common occurrence?

And also, I was under the impression that you could move tape tracks back to the OP-1 from the computer… Apparently this is an incorrect assumption?

Thanks in advance!

The crash sometimes happens to me when I unplug it too fast, but it’s usually not a problem for further use.
Regarding backup, I copy and paste the whole content of the OP-1 (album + drum + tape + synth) rather than removing it from the OP-1. Then if I want a clean tape, I erase it by pressing shift + tape and 1+2+3+4.

I’ve been pasting back 4 tape files into the OP-1 though and it worked. I did recreate the files into a daw, exported it in .aif format. The file has to be 6 minutes long, even if you just have 2 minutes of music.

Hope it helps!

Thanks for your reply, Artsun. Much appreciated!