'te-boot not working' issue solved

Hi, after struggling with this issue for a while and trying out a few things, I seem to have found a reliable and reproducible solution for the problem where the ‘te-boot’ bootloader of the original OP-1 is not accessible and therefore firmware updates and factory reset are impossible:

  1. Download the following file:
    If it ever becomes unavailable, please send me a PM!

  2. Rename it from ‘te-boot-fix.op1’ to ‘te-boot.op1’ - this is not optional!

  3. Power up OP-1 and connect it to a PC via USB

  4. Press Shift+COM and then the T3 key (DISK)
    OP-1 should show up as a USB drive on the PC soon after

  5. Copy the renamed file to that drive

  6. Press the T2 key (CTRL) on the OP-1
    Screen should now go blank for a short while and then display this message:


  1. Power off OP-1

  2. Problem solved, you should now be able to access the bootloader by holding down the COM key while powering on the OP-1!

There is a post in this forum on a thread called “Well I’m Sad - Help” (can’t post the link since I’m a new user - sorry) that is almost identical to my solution (kudos to user ‘nthn’) except he said to press the T1 key which did not work for me. My firmware version is 242, his was 241, maybe that makes a difference? I don’t know what the oldest firmware version is, that supports this updating of the bootloader from within the application, I suspect it might have been added only after this issue became known to TE. IMHO it is inappropriate and disappointing that TE does not provide this solution openly in it’s FAQ but instead often seems to be recommending a costly exchange of the DSP board to its users.

I unpacked the mysterious firmware file using the op1repacker tool that can be found on GitHub.
The file only contains the bootloader executable (v2.29) called ‘te-boot.ldr’, I suspect that the .op1 file needs to be renamed to match this name.

Warning: if your firmware version is already 243 (last version that uses bootloader v2.29) or higher then this could be a problem since I don’t know if the bootloader is backwards compatible! If you’re feeling lucky you can use the op1repacker tool to extract only the te-boot.ldr file from a later firmware, repack it and try uploading that.

Hope that helps! (If not, please post your firmware version, visible during boot)


This does not seem to work for firmware version 225 so I suspect it won’t work for earlier versions either…

I have R.14203 on my OP-1 original. I bought it in 2012 and updated it in 2014. I’ve lost the ability to get to the boot screen, and I can confirm none of these fixes work for my situation, but I very much appreciate your efforts. Any tips, ideas, or advice you may have to get myself out of this predicament? If I try and sell it, this will surely be a big hit on price. I’d like to keep it, but now I have a battery that only lasts 2 hours, and a dead mic. I can make these repairs, but if I use TE battery and the TE i/o board I am looking at almost $200 USD. TE is really bad at supporting their products from my experience with this purchase. Thanks again.