The reason why OP-1 clock/sync sucks/drifts


#1

TL;DR: When slaving OP-1, it receives MIDI clock, and its BPM counter indicates it is synced. BUT, internally, OP-1 is NOT following the clock. Teenage Engineering should fix this.

Here is how I came to this conclusion.

I sync a lot of hardware to Ableton.
I usually set a negative MIDI clock sync delay in Ableton’s MIDI settings.
I did this for the OP-1, as I normally do.
To test my sync, I recorded the OP-1’s metronome into an Ableton track with monitoring OFF of course, so as to avoid Ableton’s latency (a huge topic).
I noticed my MIDI clock sync delay settings were NOT being used.
I then set extreme amounts of MIDI clock sync delay and did the test again.
There was no change.

My conclusion:

OP-1 receives start and stop and clock. OP-1 only uses start and stop. OP-1’s BPM counter shows you it is syncing, but internally, OP-1 is only starting and stopping; it is not following the clock.

This is also why OP-1’s clock drifts.


#2

I’ve had reasonable success syncing the OP1 as a slave, + I use it live . Tape is now quite usable as a looper when synced (didn’t use to be), and sequencers were synced, but not starting and stopping. Tempo changes from my master clock are reflected on the OP1 as a slave. Are you definitely sending clock and not just MMC, and did you try another USB MIDI device as a slave? If it still doesn’t work maybe raise a ticket with TE.


#3

Thanks for the reply.

Yes, as you point out, OP-1 picks up the tempo changes and changes the tempo as reflected in its display.

But, OP-1 is not SYNCING to the clock. It’s a subtle, yet critical difference.

What OP-1 is doing is tantamount to you changing the tempo manually and hitting play at the same time as your sequencer. That’s it. It will obey tempo changes, but its actual clock is not synced. That is why it drifts. Of course it is going to drift working this way.

To answer your questions, yes I am sending clock, not just MMC.

My other hardware does not do this.

This is easy to test using the method I described above.

This needs to fixed so that OP-1’s clock does not drift and so that OP-1’s clock can be offset properly like all other synced hardware.


#4

I only get drift as slave if whatever I’m looping on the op1 is not 100% perfect. Since all the beats get recorded to the tape there can sometimes be slight inconsistencies when looping beats if it’s not 100% lined up and eventually it starts to drift. You can test the real sync of the op1 better if you only have one of the sequencers running with no audio looping on the tape. The endless sequencer is the best for this test but of course you have to manually start it. Once it’s running it should go along with your clock and sync when adjusting the tempo too. Overall I think the real culprit here is ableton’s midi jitter. Ableton’s clock will drift and is not really reliable when clocking multiple hardware units. I usually always just have the op1 as master but that will not work for everyone.


#5

Thanks for the reply. But, I am testing with OP-1’s metronome. Can’t imagine a better way.

Respectfully, I think Ableton’s minimal jitter is not the culprit.

If OP-1 were properly syncing, then it would be effected by Ableton’s MIDI clock sync delay. But it is not.


#6

have u done the same tests on the just the sequencers?

i wonder if this is what they mean by directly driving sequencers
from your other thread on here.

that is how i would interpret those words

that maybe the sequencers are being advanced based on the pulses it receives
and not just based on the BPM setting of the op1

which is i think what you are getting at, if i am reading u correctly?
that the clock signals are feeding the BPM of the op1, which is then feeding the tape
and not that the clock pulses are advancing the tape itself.

since the tape is really not step based at its core, it sorta makes sense that they implemented it this way


#7

Yes, I have done the same tests on the sequencers. Those are an even more special case, since, unless they are in hold mode, they fire depending on when you trigger them, either by pressing a key on OP-1 or sending a MIDI note.

In my tests with the sequencers, I could not find any rhyme or reason with how they play with the MIDI clock other than simply receiving the tempo information. Where the sequencer notes land depends on when they are triggered.

Yeah, “directly driving sequencers” is odd. I am not sure exactly what Teenage Engineering means by that. Perhaps they mean that the sequencers will advance in hold mode. I dunno.

What I am getting at is the OP-1 does not maintain sync from a MIDI clock, unlike almost all other sync-able hardware.

OP-1 starts, stops, and updates its tempo data. But it does not sync.

If you look at OP-1’s tempo, you’ll be tricked into thinking it is syncing, since the tempo values fluctuate. But, again, OP-1 does not maintain its sync; it only uses the received MIDI clock to change tempo, start and stop.

Therefore OP-1’s clock drifts, and it cannot be offset properly like all other synced hardware.

I concede I could be wrong on this, but all my tests and all the user reports about OP-1 clock drift point to this being the case.


#8

FWIW, OP-Z works properly, like all other sync-able hardware.


#9

I think I see what your saying about the op1 not being in ‘sync’. My theory is that the op1 is getting clock but since there is a small amount of jitter coming from Ableton or whatever else is the master, the tape on the op1 will eventually drift. Since the tape is audio and not midi data it can’t adjust to the clock like the individual notes of midi data. This is why I have better luck using the op1 as master since the op1 tape loop points are not moving around. (take a real close look, the tape loop start and end points move when it’s a slave). Also I don’t think the metronome gets midi clock, just tempo info.


#10

@jbone1313 said:
Thanks for the reply. But, I am testing with OP-1’s metronome. Can’t imagine a better way.

Respectfully, I think Ableton’s minimal jitter is not the culprit.

If OP-1 were properly syncing, then it would be effected by Ableton’s MIDI clock sync delay. But it is not.

The op1 metronome doesn’t sync to the tape, maybe it’s something to do with that.


#11

@ludicrouSpeed said:

@jbone1313 said:
Thanks for the reply. But, I am testing with OP-1’s metronome. Can’t imagine a better way.

Respectfully, I think Ableton’s minimal jitter is not the culprit.

If OP-1 were properly syncing, then it would be effected by Ableton’s MIDI clock sync delay. But it is not.

The op1 metronome doesn’t sync to the tape, maybe it’s something to do with that.

I would say it the other way; the tape does not necessarily sync to the metronome. But, the metronome ostensibly syncs to OP-1’s clock.


#12

@jbone1313 said:

@ludicrouSpeed said:

@jbone1313 said:
Thanks for the reply. But, I am testing with OP-1’s metronome. Can’t imagine a better way.

Respectfully, I think Ableton’s minimal jitter is not the culprit.

If OP-1 were properly syncing, then it would be effected by Ableton’s MIDI clock sync delay. But it is not.

The op1 metronome doesn’t sync to the tape, maybe it’s something to do with that.

I would say it the other way; the tape does not necessarily sync to the metronome. But, the metronome ostensibly syncs to OP-1’s clock.

Ah, interesting


#13

Best to leave the tape out of this, since the in and out (and hence loop) points are marked in absolute position terms. when the midi clock or tempo changes, the interpreted marker positions change on the display, but the in and out points remain absolute and if it’s looping, the loop does not change position or length.


#14

I’ve had problems with syncing the op1 without drift for a long time.
I’ve added a erm multiclock as master clock and the oplab.
And since the latest update it’s running rock solid.
No drift!

It’s really great!
If you remember which pieces of tape are in which bpm.
(I use pices of tape for different songs in different bpm)
It will put the markers correctly.