USB audio completely mangled while phones audio sounds clean

I just got my second hand OP-Z a few days ago and I’ve been having a blast with it except I can’t actually record any of my songs.

I was depending on the USB audio out capabilities but everything over USB sounds distorted/peaky/oversaturated, completely unusable audio. At the same time the audio out over my headphones sounds completely normal.

  • I’ve tried turning down the volume dial but that doesn’t do anything for USB.
  • I’ve tried disabling USB charging but had no change.
  • I found on reddit that it might be related to the latest firmware so I downgraded from 1.2.17 to 2.1.14 but had no change.
  • I’ve tried a whole host of various orderings of connecting, disconnecting, restarting, different ports, different cables.
  • I’ve tried on windows 10 and my android phone, both exhibit the same issue with USB audio.
1 Like

Following, I have the same problem. The first batch of OP-Z and latest firmware.

1 Like

Have you tried changing the audio buffer? Try something larger (longer). There will be more latency though.