Using OP-1 as a control surface for Ableton not working after 243 update


I’ve been using my OP-1 as a control surface with Ableton live 10 on my mac, but after I updated the OP-1 to the latest firmware (243) now the OP-1 doesn’t control Ableton as it did.

Before all I had to do was plug my OP-1 into my mac press [shift] + [com] on OP–1 and enter ctrl mode using [T2]. then I could control ableton.

Now nothing happens, the screen on the OP-1 used to change depending on what mode I wanted like perform, clip, tape or mixer.

I’ve tried reinstalling the script from here: GitHub - marctdt/op-1-ableton-live-control-surface: Ableton Live Control Surface for Teenage Engineering OP-1

But this doesn’t do anything.

Any help much appreciated.

checked the midi channel yet?

Yes I tried that, still nothing :frowning:

same problem here, waiting for solution.

I downgraded to 242 and it’s working again, being able to control Ableton is worth more to me than audio over USB so I don’t miss the 243 update.

do you have any videos of how this works?
i can’t seem to find any

had no idea op1 could do anything beyond simple midi controls for a daw plugin

1 Like

Found out something you may try: Shift+ blanc controler turn until screen shows " midi cc" under a “< >” on the right under the midi channel indicator.
The keyb display remains the same, not showing then modifier display of keys avalable as before, but commands seems to do it ok.