Firmware update - 1.1.27

firmware

#21

Well that’s awesome… So can you have more than one sample on a track or just one? Sorry for all the questions, this is pretty epic, my digitakt is mono so I can just move them over from that.


#22

What does that mean? The sample has to be c4 or that’s were it puts the root sample?


#23

I think the sample will not be correctly tuned if it is not already a C. One per plug per track. I don’t think there is a way to change the tuning of a sample at present.


#24

A plug is the black buttons right? So you can have many?


#25

Correct. Ten plugs per synth track. 1 sample of six seconds max per plug. Mono sample


#26

Didn’t fix my left only sound. Maybe I was too optimistic.
Waiting on that RMA…


#27

That stinks. Did you try a factory reset?


#28

Well that’s just rediculous cool, I really need to learn how to move sounds over… that’s really cool.


#30

Yup. Took a while for TE to reply to support requests but eventually (3 weeks) got a message to go through their RMA process. Just hoping that it’ll come soon. It just misses my holiday that it’d be perfect for.
Still happy for the updates to be pretty regular regardless :slight_smile:


#31

Anyone having issues with this update? Seems to be problems related to user samples, lost projects, crashes, samples with wrong transpose settings etc.

I’m trying to determine if the 2 new samples I added are the cause of the instability or if there is some other reason.

I had lots of samples added before the update and no such issues, those samples were all op format, the 2 new samples I added were just wav in synth slots, those samples play as expected but the earlier added samples do not.


#32

I have used it for a few hours after the update now and no problems here.

The few user samples on the synth track downloaded from op1.fun are playing as expected. But I can not check if they were transposed up or down an octave because I did not use them in any of my tracks.

The samples on the drum tracks created with the OP-1 export tool in Renoise are playing fine as well.

No noticable changes on the projects also. Am enjoying the update so far.

However, I have a suggestion: how about enabling looping for the pcm sample player on the synth tracks? Maybe instead of the drone drone mode there (track parameter green dial far right). This mode does not make sense there with the 6 sec limit anyhow or is it?. This would unlock the near infinite potential of single cycle oscillators and other fun stuff, like additional asynchronous sample loops on the synth tracks, now that it is possible to latch the notes. For instance, one could use the OP-Z then like a set of 8 tape recorders with 4x12 sec and 4x6 sec second loops max each respectively. Now add sampling through the mic or the already available line in input and bingo!


#33

Hello Darenager be careful to let a little bit of space empty on the OP Z . I used to put a lot of sounds to match 31 Mb of the space and my OP Z crashed a lot. Now I’m sticking to 28 or 29 Mbits to leave a little bit of empty space. I think the OP Z is ike a computer. It needs a little bit of free space to exchange data, or data buffer, etc…


#34

@darenager - luckily never had a crash but I am experiencing issues with samples and projects and presets that I made - the same as your description.
2 samples are playing back incorrectly transposed from C to F and presets on my own samples in ‘some’ cases have reverted to a state as if I had just imported them (which I find really strange because there’s no obvious logic to this (to me) right now) - they need adjusting on the first white control to get rid of noise and the green LED page ADSR (DS) needs adjusting to get the volume up. I know I did not import these samples without tweaking and saving them in a state that I could use them.
Maybe rash of me but I am gonna wipe it and start again. I’ll report back if things are still iffy after I do that.


#35

Thanks, yes very similar to what I’m experiencing, I guess once a few more folks who have loaded in samples prior to the update start reporting in we will have a better idea on the actual cause and be in a better position to file bug reports, I have not reported to TE yet as I have not properly diagnosed the exact conditions of what causes the crash and why the samples and how many are affected.


#36

Thank you so much! You’ve just solved a couple of hours of frustration trying to understand why temporary parameter tweaks were increasing the FX 1 sends on my OP-Z! I even tried to factory reset!

Tank god for you comment :pray:t3:


#37

Yeah it’s pretty weird. I’ve been looking and I don’t seem to find anywhere in the manual where it says fx 1 is applied to temp peram tweaks. “Pro-tip: use shift combined with the color dials for temporary tweaking of a parameter. release shift to revert back to previous setting. this is great when live jamming!” Is the only mention I can find


#38

yeah. and someone found out that fx a raises by this method! TE stated at this time that it was by design! i think with the general.json document TE has found a good way to implement such changes.

i hope a record button stays lit with highest priority function comes next. + parameter recording while OP-Z is just in record mode, without pressing the rec button


#39

Ok here is a test to try, add a 16bit mono wav file to one of your synth slots, make a pattern in a empty project using that sound, now try to connect to the app whilst on that pattern. Note running or not doesn’t matter.

On mine the OP-Z crashes, first step LED goes white, then the 4 encoders LEDs go white and the first step LED flashes. Edit: it goes into fw update mode.

Now restart your OP-Z change to a different project where the sample isn’t used, try to connect to app, should connect fine, now while still connected to app change to the project with the new sample, crash, into fw update mode.


#40

hi, I’ve done the test you suggested and everything is working ok on my unit. No crashes no matter what I do in whatever order both with app on my iPhone 6S IOS 12.0.1 and the app on a 2017 MacBook Pro 10.13.6 HighSierra.
I loaded a random mono 16 bit 44.1 .wav into a Bass slot. (4 seconds wav to see how it would handle it)
However - I did as I said I would earlier and wiped the OP-Z. I then re-imported some projects and all custom samples and for some reason everything seems ok to me now.


#41

Did the suggested test also. Loaded a 16 bit 44.1 wav file, a C, into the bass slot nr 7. The OP-Z connects to the app with no problems and no crashes, also when changing back to the project with the imported sample.

As it seems, the original frequency of the sample plays on C5. Good to know.