iPad won't recognize MIDI input from OP-1

Tried searching for others who’ve had this issue, and didn’t find any, so here goes:


Attempting to use the OP-1’s midi out data to control various iPad synth apps. Bought an Apple Lightning to USB adapter. iPad in question is an Air model, full-size, running latest OS.

Connect the OP-1 to the iPad using the mini USB out on the OP-1, into the adapter, then into the Lightning port on the iPad.

Shift-COM, switch the OP-1 into CTRL mode.

Within about 15-20 seconds of connecting the cable to the iPad, I get the dreaded “This Accessory Is Not Supported By This Device” pop-up on the iPad. Have tried various iPad apps (iMini, Alchemy, Grain Science, Animoog) and none of them seem to be picking up that there’s a recognized MIDI device connected.

Have also tried various combinations of toggling the OP-1 on/off, resetting the iPad, doing the powerup/connection sequence in different orders.

Has anyone experienced this, and is there a recommended solution? Thanks!

r u using a third party CCK? or an apple brand one?


do u have usb charging turned on? i think u would want it turned off

Using this one, from Apple: http://store.apple.com/us/product/MD821ZM/A/lightning-to-usb-camera-adapter


have tried it with USB charging on, and also with it off. Doesn’t seem to make a difference.

have you tried using it without ctrl mode? it still spits out, and responds to, MIDI while in OP-1 mode.

Wait, so you’ve tried it with combinations of what to connect to what first? Like this: with the OP-1 on, attach the usb cable followed by attaching the CCK, then plug it into your iPad. I think it needs to be in the order.

Did you try another USB cable?

So I did try it without CTRL mode after I posted yesterday. After some random sequence of events, involving switching the OP-1 mode, unplugging and re-plugging, I was able to get various iPad apps to at least detect the OP-1 - saw the “OP-1 Midi Device” listed under the list of MIDI inputs.


Unfortunately, despite it showing up on the list, the actual keys/knobs were not causing the apps to respond.

Kites - I have tried that order, with no success. Have not tried a different USB cable, but I can see about that. I’m using the standard cable that came with the OP-1.

One thing I’m wondering - it seems like the Lightning to USB adapter doesn’t work for a variety of cameras, based on reading some reviews on Apple’s site. Has to do with power requirements or some such. Perhaps the OP-1 and iPad Air just aren’t friendly, along those same lines? All of the videos that I’ve seen of folks using the OP-1 with their iPad have either been Minis or previous generation iPads. Is anyone here successfully using their OP-1 with an iPad Air using the Lightning to USB adapter?

Yea me! I’ve been using the OP-1 with my iPad air since January. It was a little tricky at first, but once I got the right order of things connected, it worked every time. Currently I run the iPad Air with an iTrack Dock and I can record audio from Op-1 while also recording the midi notes.

I’m wondering if it’s OS update for either your OP-1 or iPad, although, my iOS 7 is an earlier version (jailbroken), it still recognizes the OP-1. You can try reformatting or reinstalling OP-1s OS if you haven’t already.

All the apps you’ve mentioned above should at least trigger sound from the Op-1s keys. I use Alchemy myself and the keys work automatically - it’s only when I want to modulate Alchemy, I then need to assign midi to whatever encoders on the Op-1 I want.

can you check with a camera and see if it works as expected there? I have never had problems with iPads and the OP-1.

the other thing to check is you are using the right midi channel for both… so if your app expect 10 in the case of a drums the OP-1 is set to 10 if you are doing any other synth they are usually set to 1 unless they are set to omni in which case 1 or 10 would work.

what app on the iPad are you trying to control?

…think you will need an Oplab or iconnectmidi etc.


correct me if iam wrong. sounds like you are plugging it straight to the ipad. between the operator and your ipad is a cck!

@johnnyego, the CCK acts as a usb host, so there is no need for oplab, ICM, etc.

Kites - I know you’re using the iTrack now, but have you tried using the Lightning to USB camera connector before with your iPad Air?


I tried reinstalling the OP-1 OS, and it didn’t make a difference - still seeing “This accessory is not supported by this iPad”.

I’m updating the OS on the iPad to the newly released 8.0 to see if that makes a difference, and then the next step will be to try a different USB cable out of the OP-1, though it seems unlikely that that would be the culprit. Thanks to everyone for chiming in… determined to figure this out!

dimi3 - have not had a chance to try a camera yet, but I will. Midi channels are lined up between apps and OP-1 out, both on channel 1.


apps I have tried : Alchemy, Animoog, iMini, Grain Science. All supposedly work with MIDI in.

Ya I use the CCK too. Have you tried using the OP-1 USB cable with a computer? If it’s not that then it comes down to the CCK.

Yeah, I’ve been able to use the OP-1 with the computer to back up sound files and such, no problems there. So weird!

Hmm, did updating to iOS 8 do anything?

Afraid not. Figure my next bet is to try getting a new Lightning to USB adapter from Apple.

Damn, that’s an odd one. Hopefully exchanging the CCK will help.

Any luck?