Mac will not allow me to update any FIRMWARE! anyone?

Hello there, bought OP-Z in April this year…still has firmware 1.1.17 on it, never updated. Today tried to update to latest 1.2.5 (sampling) firmware. When plugging in OP-Z to mac in Update mode I get an error message from my mac saying “OS X can’t repair the disk “OP-Z”” and it suggests backing up the disk and reformatting it…obviously I don’t want to do that. I can open up the visible OP-Z drive from my desktop. The problem then is that when I drag and drop the new firmware update into the root file it will not stay, displaying the incompatibility icon (circle with line through it) . This is the same for ALL updates. So I am stuck on 1.1.17. CAN ANYONE please help me understand what to do here…I am really looking forward to get into the new sampling mode! PLEASE ASSIST thank you in advance, OP-PEOPLE

When you get the “can’t repair disk” warning on a Mac, the message usually says additionally that you can still read from, just not write to the disk, so that part is normal. You can reboot your Mac and try again, but you’ve probably already done that. You can try rebooting your Mac to recovery mode (by holding cmd-r while it boots), then run Disk Utility from recovery mode and see if it still reports that it can’t repair. Can you access another Mac to compare? I updated on my Mac, no problem.

Thanks for the reply, buddy. I’m not sure why booting in recovery mode will help, are there other consequences to this IE i have a lot of important stuff on my mac, will it be affected by recovery reboot? Also I’m a bit unclear as to what i am supposed to be able to do here, the message reads additionally: ‘You can still open or copy files on the disk, but you can’t save changes to files on the disk. Back up the disk and reformat it as soon as you can’ So this is kind of as you described, so that’s cool…but my question is WHY. I will try what you suggest but possibly if you could fill me in a little if there are any risks to data in recovery mode? Your time is much appreciated, mate

Recovery mode doesn’t risk anything unless you intentionally do something obviously destructive. It’s just exploratory to see if perhaps the OP-Z won’t be seen as damaged from recovery mode, though I expect MacOS will complain there, too.

I also wish I knew why this happens. I’ve had it happen on two 8TB backup drives in the past week. The pair mirror each other, so I simply re-formatted and copied all files over. That copy, though, took eight hours, and it’s aggravating.

Put your OP-Z first in update mode, than connect it to your Mac. Maybe that works.

Wait, your OP-Z wasn’t in update mode?! That’s surely the issue.

Yes try it in a different order. And it will work.

hi there…yes it was definitely in update mode…hold screen icon and turn on

tried that it doesnt make a difference…still mac sees op-z as a damaged disk etc

OK. When you boot to recovery, I should have mentioned to run Disk Utility, then see what it tells you.

you mean with the op-z attached?

Yes. Sometimes running Disk Utility from recovery mode gives more accurate info, and will maybe offer a clue, though it’s a long shot.

ok appreciate it buddy…i will try

why don’t u want to repair/reformat the disk?
might be exactly what u need

or atleast will tell u if your Z drive is shot or not

Factory reset for the op-z?

Ok SOLVED IT…I waited for the wife to come home and used her mac instead, she has later OS, so maybe it was that…anyway, she’s a doll…I’m going to sample her immediately.

THANK YOU TO ALL WHO REPLIED TO THIS THREAD, much appreciated, now we are all SAMPLE-PEOPLE, OP-PEOPLE, Z-PEOPLE, yeah!

Hey, did you ever happen to find a way to make this work with your older mac OS? I have the exact same problem…

Hey, which version of OS X are you using?

Yosemite 10.10.2

I just had the chance to test things on an old MacBook (OS X 10.6.8).

Having the OP-Z connected via USB, I turned it on while holding the screen button. After a few seconds, I was able to access the OP-Z partition, being able to read and write to it without problems. The OP-Z partition is formatted in FAT format, which can be read and written by OS X.

Having this observed, I’d say that your OS X Yosemite should work just fine.

In your case, it seems like the partition table got damaged somehow, which might be the reason for the error message and the operating system offering to repair it.

@physicalgoose:
Please try the following steps:

  1. Connect your OP-Z via USB, hold the screen button and turn it on.

  2. Open the OS X Disk Utility

  3. Select »[…] teenage OP-Z Disk Media« on the left side of the program

  4. On the right side, select the first tab named »First Aid«

  5. The program should now present you two buttons »Verify Disk« and »Repair Disk«. Use »Very Disk« to let Disk Utility check the OP-Z partition for errors and »Repair Disk« to solve them.

Let me know if it worked for you.