MIDI Out to TT-303, Note held

tl;dr: MIDI notes sent from OP-Z to TT-303 via iRig Pro are held and never released
Hey there,

Today I wanted to use the sequencer of the OP-Z to control my Cyclone Analogic TT-303 Bass Bot v2 but I couldn’t get it to work. I use the iRig Pro to send and receive MIDI from/to the OP-Z and syncing works with this setup. But if I switch the TT-303s mode to MIDI and try to send notes it does not seem to work. OP-Z sends on the same channel that TT-303 listens to and sometimes a note is sent and received. The problem is, that the sent note is held and every note played afterwards is played as a “slide” note by the TT-303 (the signal then gets quieter over time, because the TT-303 treats every following note as slide, as long as the previous note is pressed). Also it seems like i can’t stop the note from being pressed then, once it is played. Even if I remove the midi cable from the TT-303 the note is still pressed so maybe something made it crash? Creating a blank project also didn’t solve the problem and i wasn’t able to find a solution by reading the manual. I’m using FW 1.2.31
I tried to control the TT-303 with my Octatrack which worked fine so im wondering if there is an issue with the iRig Pro being used with the OP-Z, the OP-Z itself or with me operating the OP-Z.
Is there a way to get this setup to work?

i think u just answered your own question
sounds like the notes are overlapping
which is causing hte slides
u prolly need to adjust the note length so that each note off gets sent before the next note on

Thanks for the hint. I was using the Arp-Track to send midi which seems to be the problem (I don’t know why though). Just tried the same thing with the chord track which worked. Tried it with other tracks which didn’t work. Summed up:

  • Note length works with the chord track but does not seem to affect the others.
  • If i press a note with the arp-track, it is sent, but never released
  • It does not play arpeggio, only the single note
  • Steps from the arp-pattern are not sent (just connected it to Ableton - I connected it via iRig again - and it doesn’t show any incoming midi signal), only notes played live but steps from the chord pattern are sent.
  • All tracks have the same settings in the midi setup
  • Notes from other tracks are not sent, even when playing live (I have tried sending/listening to different midi-channels)

I’m really puzzled since i don’t know what there is that i can change besides the settings in the midi-setup and stuff like note-length. Am I missing something or could OPZ+iRig be a bad combo?

Update: I connected the Opz directly via USB-Cable to the computer and it behaves in the same way as when connected via iRig, I guess this wasn’t the problem then.

1 Like

Ok I was able to fix it: The fact that iRig wasn’t the cause led me to another thread which mentions that midi tracks can be muted. So i checked and realized, that every midi-track but the chord one were muted :man_facepalming:
Solution was found in https://op-forums.com/t/op-z-midi-question/17885/6