New OP-1 OS #235


  1. The button T3 ceased working again. Smells like a trip to Sweden is to be envisioned…

  2. My OP-1 froze with a wild noise in the middle of a live PA yesterday. Never happened with previous OS.


Custom Firmware on the OP-1

@LyingDalai Unlucky buddy, I hope it gonna work well soon. Have you tried to retrograde firmware ?

On my side, my Op-1 is still running the 218 firmware, I haven’t updated it for a while !


Anyone else have any troubles with the new OS?

Or is it working okay for most folks?


Heh, after this thread I’m scared of updating.


My T3 was dysfunctional way before #235 update : it’s really my synth that is not working properly.

Regarding the crash during the live performance : it happened once only, got to check this further but it might be related to above problem. Apart from this it’s a really cool OS, Shift+STOP is such a great feature to have !


Beyond that single case of switching to mono suddenly (I haven’t experienced it since then) I have no issues with #235.
There are still some small problems but they were already present before this new OS.


Now that I think of it, one thing I should try is to do a whole reset.
Might do some good.


It has the old mixer icons lol. Nice find!


I will re-try this today. I was disappointed last time. Glad i got that C adapter.


I’m having issues installing. My OP-1 works fine but when I try and enter boot mode (hold COM while turning on) nothing happens only black screen. Any suggestions?


Might be a corrupted bootloader. Have you ever been able to enter boot mode?


@quarantequatre If you’re still on old firmware would you mind to check if you can reproduce this issue found in #235 and detailed in the first post of this thread?

Just to ensure that this is a new bug introduced with the latest firmware.



This request is also open for everybody, who’s still on OS older than #235. It would be good to prove that we’re speaking about a new bug.
Anyway I encourage people with #235 to check the topic about the bug I linked above to reproduce the issue. Hey it takes about 1 min to try it out :slight_smile:


thanks. Never had reason to do it as it had the latest firmware when I bought it. Any suggestions how i can fix it?


I’m afraid there’s no way to fix it yourself. Is it still under warranty?


Is the high res mode 16th notes? 1/4 notes, or 1/8 notes?


I bought it last May, so it is under warranty. I contacted TE a few days ago but no reply so far…


Have you purchased it directly from TE? If not, it’s better to let your retailer deal with them.


theres several levels from 1 bar to 1/8 notes


I had some erratic/intermittent buttons on my unit as well - unfortunately 1 ended up being a bad rubber switch membrane which was cracked, which meant the pad wouldn’t contact the carbon switch properly. The other was solved with a tiny amount of contact cleaner injected under the membrane switch.

Still waiting for new keyboard assemblies to show up @ iFixit so I can replace/get back to Operating.