OP-1 <--> OP-Z Sync Thread (Post updates #235 & 1.1.23)


#1

Following the update of the OP-Z & OP-1 this week, I had my hopes up for a true solution to the seemingly incompatible OP-1 tape and OP-Z sequencer. As of right now, after I tested them for some time, the units are STILL experiencing the same sync issue I wrote to TE about 2 months ago. The issue is as follows:

OP-1 is Master (Beat Match mode), OP-Z is slave (only Clock in / Midi in enabled) connected by a usb c <-> usb mini chord (amazon).
When metronomes are turned on for testing the issue and the OP-1 tape has a loop point set, when the start button is pressed on the OP-1, both devices trigger inconsistently and out of sync.

This method is the closest to reliable I can get when testing all clock possibilities for the two units. I sent a video demonstrating this same issue to TE and they responded with “we are looking into it”. They obviously didn’t find a solution and I am losing hope in these devices.

I figured, there must be some protocol or solution that would force the OP-Z clock, (while slave to OP-1) to start the sequence in perfect tandem with the OP-1’s tape. Even some sort of “OP-Z control” mode for the OP-1 (like the PO-sync mode), that circumvents the limitations of MIDI here, allowing the unit’s state commands, like play, stop or tempo etc. to drive the OP-Z’s sequencer… IDK this isn’t my job, but this just baffles me that they haven’t made this work yet. Im so dismayed.

I also bought an RK-005 to solve this, but it doesn’t do anything for the problem.

Any thoughts?


What can the OP-1 and OP-Z do together?
#2

My two devices are syncing correctly after the two firmware updates.

When setting the OP-1 as master, besides putting it in Beat Match Mode, check your OP-Z midi settings and DISABLE clock out, ENABLE Clock in + MIDI in.

For the OP-Z as master, switch the OP-1 to Syc mode and in the OP-Z’s midi settings make sure Clock Out and Midi out are ENABLED. And of course, disable Clock in,

ALSO, do this at the start of the Tape in the OP-1. Haven’t tried with loop points further down along the tape, but playing right from the start of the tape with or without a loop, syncs.


#3

I’m using the OP-Z as the master clock here, but I’ve got the OP-1 sync’d over USB midi (USB-C <-> Mini USB cable), and then an Elektron Model:Samples sync’d over MIDI from an oplab module (beta tester). All looking good so far.

I’m not a huge expert, but I’ve heard the OP-1 isn’t a great master clock and the OP-Z is much better. But I also haven’t played much with the tape and how that impacts things.


#4

I have the same thing. With OP-1 as master, it only syncs correctly when starting from the beginning of the tape.

I use OP-Z as master, and it works great.


#5

does it work anywhere in the tape when you use op-z as master? what are your settings?


#6

What kind of cable or adapter are you guys using? I just picked up a cheap USB-A m/f converter and it seems to do nothing. Any tips on what I should be looking for?

I put it in the OP-1 and connected it to the OP-Z using the official Z-cable.


#7

I use the Apple USB c to USB a convertor cable. ANd it works instantly.


#8

absolutely stable now. :+1:


#9

Not for me. I experienced that op1 and opz are running out of sync over just a few beats if I use the Arpeggiator or the Apes-Sequencer. I tried to have both units running (and they started just fine), but if I setup a loop in OP1 and try to start a beat synced recording with one of the sequencers, they run out of sync after some beats. CAn anyone else confirm this?

Latest os on both devices. OP1 is master, OPz responds to start/stop. Connection via USB-Cable, OPz is set to just receive sync and notes.


#10

USB should all be the same. I have also found some cheap cables just don’t work. I can’t figure out what it is in the product specs of the units that don’t work. USB should be universal, but it definitely is not.


#11

they are not all the same.
some cables are for power/charging only
not data transfer/sync

u always want a cable that does POWER AND DATA


#12

I have the same issue although I’m using the original oplab usb ports to send clock to the opz from the op1. Sometimes the opz will start on beat but eventually both units go out of sync. Also when playing with the op1 sequencers it quickly starts to go off sync too. Usually I’ve had reliable clock from the op1 with other hardware so not sure what the culprit is, op1 or opz. We probably need another firmware update to tighten things up.


#13

I’m having no luck trying to send midi clock from op-z to op-1 and ipad through an hub usb.
It’s a strange situation because my iPad is correctly receiving the clock, while the op-1 doesn’t.
But if with the same setup i set the iPad as master my op-1 is receiving correctly the clock so i suppose they are both configured correctly.
both devices have the latest firmware.
any ideas?


#14

Nucleum hub?


#15

Have you tried midimittr to ensure midi routing is fine on the iPad?


#16

No it’s a Hama but it have always worked flawless


#17

I’ve checked with with midi flow and it’s all right (infact the iPad is receiving midi clock correctly).
The strange thing is that op-1 is receiving midi clock from the iPad when i set it as a master but doesn’t work if i set op-z as master


#18

You need to route the MIDI to the OP-1. You’ll have to use an app like Midiflow to do it.

Right now the midi from the OP-Z is entering the iPad, but nothing is telling it where to go after that. You need to tell it.


#19

Thanks for the answer, i think it should do the work…
I’ve another dumb question… sorry but i’m not really a midi guy :slight_smile:
Is this the correct way to do this or is just a workaround? op-z should send midi clock to both devices and not just to one… or am i missing something?


#20

Your OP-Z is only sending to the iPad right now. Think about how the usb works. The iPad is on one side, and everything else is on the other side. The iPad can send to all the other devices, but those devices can only send to one place — the iPad.

There are midi hubs available that route everything to everywhere, but USB hubs don’t. That’s why you need a “host” — the iPad in this case — to do it.

What you could do is put the OP-Z on the other side of the hub. It will act as a usb host (like a computer does). Then you could have the op1 and OP-Z talking directly to each other, and both getting power, too!