OP-Z Firmware Updates.

How to update:

  1. Hold the SCREEN button while powering up. this will put your OP-Z in upgrade mode.
  2. Drop the firmware file in the root folder of the OP-Z disk.
  3. Eject the disk.
  4. Wait for the upgrade to finish, do not turn off the synth.
  5. Upgrade is completed when the four leds are green. the unit will restart automatically after 5 seconds.

https://teenage.engineering/downloads/op-z

2018-12-07: 1.1.17 available for download:
https://teenage.engineering/_software/op-z/z_firmware_1_1_17.zfw

2018-11-13: 1.1.12 available for download:
https://teenage.engineering/_software/op-z/z_firmware_1_1_12.zfw

2018-10-17: 1.1.09 available for download:
https://teenage.engineering/_software/op-z/z_firmware_1_1_9.zfw

Get that predownload ready, before the OP-Z arrives. That…800Kb download…could…take…a…while…?

No release notes,. just a .bin file! I suspect the shipping units will have this version pre-installed…

@SLiC said:
No release notes,. just a .bin file! I suspect the shipping units will have this version pre-installed…

Actually, it wouldn’t surprise me if they don’t have this installed. They were probably flashed a couple of weeks ago during assembly.

everything is just ready before anyone has this thing. such good vibes! iam literally shaking waiting on this niche thing. people will blow this by it‘s size but at the end of the day the OP-Z controls the whole concert place…and then comes Unity. masterpiece again.

Just updated the firmware, nice process to watch! :slight_smile:

What is the update about? More functionality?

Less bugs, most probably…

1 Like

Well you guys know me by now. So I took a look into the FW file and it seems like TE doesn’t want to let us in on the fun quite as much this time around.

  • binwalk doesn’t find any magic file signatures in the .zfw
  • The file is really small compared to the .op1 files (800kB to 11MB!)
  • The entropy of almost the entire file is quite high (see the picture attached)

That much entropy is usually a) compression or b) encryption.
Since binwalk can’t find any magic headers of known compression algorithms and the entropy just begins without any ordered, visible “header”, either TE has some very weird custom compression or (more likely) the file is encrypted. (very likely compressed and then encrypted).

  • The first 0x300 Bytes are almost entirely zero Byte values and look like some kind of mostly-empty header.
  • There is nothing that looks like a CRC as they had in the old .op1 file which is another hint towards encryption/signing because why bother checking if the file was transferred correctly when it will only decrypt successfully if it did.
  • At offset 0x4 there is an 0xFF value (or 0xFF000000 if it is a 32bit value). that might be an offset to where to write the file. That would be a possible hint why the file is so small - they have updates of parts of the system this time. (Also 0xFF000000 has a special meaning in BlackFin)
  • At 0x70 there is a 20-Byte value that looks pretty random. This could be a SHA1
  • And then the last 64Bytes of the file again seem to drop in entropy. No idea yet what that could be. Maybe a signature (ECDSA?)

Entropy: https://www.dropbox.com/s/0sg3ikeyf713t9g/z_firmware_1_1_9.png?dl=0

This is gonna be interesting ;o)

PS: ca someone with an op-z be brave enough and change a few Bits of the file and try a download? I would hope the device then yields some kind of error like “decryption failed” or something? Does it keep showing something on a connected display while doing an FW upload?

Is there a way to check the system version to make sure the firmware was correctly installed? I followed the instructions, didn’t see the leds turn green, but I looked away for a bit and when I looked back the unit looks like it’s in normal mode again as though someone was just playing on it.

EDIT: Nevermind, found it by just connecting the screen, duh.

You can check it by going to the upgrade mode in the OP-Z, connecting the device again to your computer, and checking the version number within the version file inside the Systeminfo folder

Can you upload the contents of this folder?

I just uploaded mine. The external app/screen worked perfectly before the update, but now the app will pair with my OP-Z but is unresponsive to any input :confused:

I’d advise anyone against updating until this bug is sorted out if you are wanting to utilize the external display.

try the factory reset like someone else mentioned in a previous thread

edit: link here
https://operator-1.com/index.php?p=/discussion/4719/op-z-is-now-working-in-app-again#latest

That worked! Thanks a lot!

Mine is loosing wuite often the bluetooth connection. Sometimes i press screen and somthing happens in the app but cant use the dials to navigate. Today i reseted. Helped. Then the same prob. Lets wait for an update

If your opz connects, but you cant get into any parts of the app, Its worth checking if you might have turned off midi by mistake.

On the module track (listed as I/O in the app) you’ll see the midi settings — if you turn off ‘midi out enable’, then even with your opz connected, you won’t be able to use the app (since it works via midi)

If you do that by mistake when messing around with the opz, then its pretty hard to figure out how to turn it back on. Here is how:

1- go to the module track (3 from the right)
2- hold shift (the arrow)
3- make sure 3 is lit (if not, press it)

That will enable midi again.

@Polyoptics that could be possible. Indeed i was playing with midi sync, etc. but still a bit strange that the screen button triggered something on the app. Need to re-check this. Thanks

1.1.12 is out here: https://teenage.engineering/_software/op-z/z_firmware_1_1_12.zfw
op updated

  • reduced cpu consumption, improves battery life by 5-10%

fixed bugs:

  • occasional hang when removing a connected usb device.
  • occasional crash when recieving midi identity request on startup.
  • sequencer stalling when connecting a usb device.
  • configurator sometimes causing pops in downloaded samples.
  • imported sample packs to slot 10 lost after reboot.
  • outgoing program change had inverted “alt_program_change” setting.
  • app->synth connection lost when disabling midi out under midi settings.
  • sequencer sometimes starting on last step when step by step recording.

Nice, thanks for posting :slight_smile: