Op z op lab module - how to change midi input channel

Hello Users!

Owned my OPZ for about 4/5 months now, truly love it. Bought the OP Lab Module, mostly just to use my 5-pin midi out driver-less keyboard to play the synths - works perfect =D

What I am struggling with is connecting it with my electronic drum kit - Alesis Surge (Old ‘Nitro’ rebrand) - I usually have zero issues when connecting 5 pin midi out of Alesis Surge to my Korg Volca Drums (or any other Volca) - my electric drum kit will play the Volca no problem (with a slight adjustment of the ‘midi note’ setting on the Surge, I quickly find the right note i.e midi note 47 plays the crash on the Volca, no issues.)

The Midi In port on the OPZ Op Lab Module lights up when I hit any pad on the kit, so it is receiving things, but doesn’t seem to trigger any notes on any track on the OPZ. I can get the Alesis Surge drum module to ‘play’ the sequence on the curent pattern on the OPZ by simply hitting the Start/Stop button on the Alesis, so it definitely send midi to the opz, but why can I not just play the drum kits from the OPZ using the Alesis drum kit as the trigger? Should it not be as simple as the way my midi keyboard just triggers the OPZ tracks? (I can play the drum tracks with the keyboard but I want to play it like a real kit, just trigger the sounds from the OPZ not the Alesis Surge)

Ive been really frustrated by this, searched the Alesis Surge manual & Opz Op Lab guide back to front and just cant seem to get any individual notes played out of the OPZ via the Surge. I have tried turning Local Midi off on the Alesis, tried General Midi On/Off - nothing triggers individual notes on any track of the OPZ, but the Op Lab Module lights flash as I hit each pad. I have tried setting the OPZ Op Lab to only receive midi in, turning off all the other options of midi to simplify things, nothing. I have tried the ‘Channel 1 to active track’ setting.

I believe the Alesis Surge drum kit send midi out on Channel 10 - Could this be the issue? I’ve tried changing the “Channel” setting on the OPZ app, on the ‘Midi Settings’ to match it to 10 but this does nothing. I think this refers to midi OUT channel not what channel it is receiving midi IN from.

The main issue may be HOW TO CHANGE MIDI INPUT CHANNEL ON THE OPZ.

Im pulling my hair out, so any help PLEASE???

Cheers in advance

Myles

did you unmark the „channel 1 on active track“ option?

the op-z sends and receives on separate channels, if you want to control track 3 with channel 10 all you have to do is to set track 3 to channel 10, enable midi in and it should work.

If it doesn‘t but you receive midi on channel 10 by default I would try to link track 10 to track 3 to play these tracks simultaneously.

Hello

Firstly thanks SO much for the quick responze. I have tried going through all the “Channels” on the OPZ app in the midi set up whilst on the kick drum track (track 1), but no avail. Have also tried unmarking the ‘channel 1 on active track’ - but it is hard to say if I have done it with the combination of trying all the channels.

Can I ask what you mean by ‘link track 10 to track 3’? Just if you could explain differently or post a picture of what you mean, really appreciate it.

For example I have a whole kit I have put into my OPZ in the Kick track (it is a roland CR78 drum machine, each note on the opz keyboard plays a separate part of the cr78 kit of course) - so you say I would go to the OPZ app and change the “channel” in Midi settings to 10? Because this is what I have been doing, seeing the light flash up on the opz module, but hearing nothing played back through the OPZ.

It surely should work!

to „link“ tracks you have to hold down the track button then select track 10 hold em both and select track 1.

Track 1 should now blink and track 10 should stay solid white.

are you sure the drumpad is sending on channel 10?

1 Like

Also make sure midi echo is active if you are trying to play devices midi downstream from the Z. I wanted to sync my bop pad to the Z, but play the midi sync’d Division Drum 01/IV sounds. With midi echo off, only the Z’s sounds would play.

1 Like

THIS WORKED!

Thanks so much for this help. I hadnt seen anywhere before about “Linking” the channels together so this could be very useful for other users. I hadnt seen Linking in the OPZ manual anywhere but maybe I was looking in the wrong place.

It was channel 10 (0) that the midi was coming in from the Alesis Surge (this may be the same in other Alesis drum kits maybe for others?)

Thats for your quick resolves!

Cheers

Myles

1 Like

wow, how did you come across this information? midi spec for OPZ is lacking. i Thought i knew all the ins and outs til now!

1 Like

Your tips worked and now I can hear my midi drum kit play the OPZ, but I cannot seem to get it to record the things I am playing? So it monitors the sounds it should (after changing the MIDI note of each pad via the alesis surge drum module on the kit to get each pad to play the desired sound on the selected track on OPZ) but when in record mode i start playing loops on the alesis but nothing seems to be adding steps, just playing back the notes.
In addition there can often be times that playing the alesis wont trigger the OPZ, if I hit a pad 10 times in quick succession it may only translate to 7 notes being played back from the OPZ - not latency as such but randomly missing notes.

Any thoughts on this?

And thanks again in advance for the wise words (y)

1 Like

a linked track does record the incoming midi messages but in order to work you have to link both tracks, set them to the same channel and enable midi echo.

for the missing hits I would try to experiment with the trig sensitivity settings inside the Alesis.

Hi
Ok so can you explain please a little more what you mean by “link both tracks, set them to the same midi channel” - So I have linked 10 to 1 (however cant remember right now, not in front of the unit, if its 10 to 1 or 1 to 10 but on any occasion one combination works) and are you suggesting I then need to reverse this as well, like then link 1 to 10? Would this not override the original linking? -

Then you suggest setting them" both to the same channel" can you explain this a little more, do you mean in ‘Channel’ section of the “midi set up” on app or is that unaffected regardless?

Thanks

if you link tracks the blinking one is slave.

you don’t have to link them in both directions but in order to record something to the slave track you have to set track 1 to channel 10 and turn on midi echo. both in the midi setup of the app

2 Likes

I have tested the described situation and the Op-Z won‘t record to both tracks simultaneously!

the last time I did it with the chord and motion track in order to record both, performance wise and it worked but I can‘t seem to recreate this behavior.

i have a feeling that it does work when attached to the OP-1 as the OP-1 kind of „reflects“ the incoming midi data and this separate stream of midi can be recorded to the op-z. but I‘d have to recreate some scenarios

Thanks for all the info so far, I had really hoped I could just connect this to my electronic drum kit & play it, start making sounds from the OPZ and record and loop my played patterns from my physical electric kit (like I can do simply by connecting my electronic drum kit via midi directly into my Volca Beats) into the OPZ but I guess this is just not going to be as plug & play as I had hoped. - It does play some of the sounds back but not seamlessly.