OP-Z Sending Midi CC# for Master Volume to Korg Gadget :(

Has anyone else noticed that the OP-Z is sending out a MidiCC# value for Master Volume when using it to sequence synths on iPad OS.

I’m using the Zed a lot with KORG Gadget and every time I record a sequence on the OP-Z and it plays my synths in Gadget, it sends over a command to reduce the volume to almost zero.

I’ve performed a Factory reset on the Z, but it’s still doing this weird thing…also, I deactivated Enable Program Change in the OP-Z Midi settings view.

Thanks in advance if anyone knows what’s going on.

Running latest OS on OP-Z as well.


u need to find what CC is the master volume on gadget
and then match it up to the table on this for your Z

u may be able to use the “parameter_cc_out” in the midi.json file on your Z to set your CCs to something that doesn’t trigger anything on the gadget or maybe even disable them entirely

Thanks for the info. I just don’t understand why the OP-Z is sending over these commands of CC#4 and CC#7 when I am not programming it to send these over. It’s weird that it would send these over without my input.

Also, I’m not setting any Midi Learn in Gadget for these CC#'s to be an influence on the channel. I experience the same Master Volume bug in Korg Electribe Wave as well.

When i place a midi monitor on the incoming info from the OP-Z, i see that it is sending over a bunch of Control Change Commands without my input:

I assume that these are Midi CC#1-16 being fired based on the attached screenshot.

seems like gadget may have some CCs setup as default

this chart i found would indeed seem to suggest that CC#7 is indeed tied to master volume on most of hte gadgets

on the Z CC#4 is filter resonance and CC#7 is envelope sustain

Yep. But why is the OP-Z sending these commands when i am not initiating them? Shouldn’t the OP-Z only send cc#s if i instruct it? Seems like this spewing of CC#s was introduced in the latest firmware as i did not encounter this issue with Gadget prior to the update.

Thanks for the info on this thread you two. :facepunch:t3:

I had a similar issue when using the oplab together with a korg monologue. Something always made the monologue change settings in the middle of a sequence. And I did not find a way to get rid of that behaviour and I do not understand, why the op-z is sending the information, no matter what the settings are.
BTW, in my case that was faaaarrrr before the latest FW update.

Hrmm…just seems odd that the OP-Z would be firing off these random CC# values without user input. I wonder if we have to create INIT Patch on the synth parts to make sure no CC# automation is sneaking thru the midi out events…

So far what I’m doing in Gadget is setting CC#1-16 to off, and I’ve deactivated Send MidiClock from the OP-Z and it seems to work…will have to test more though to be sure :thinking:

Hello from the future!

Did you manage to resolve this issue? I’m having the same problem with the Z sending cc messages to turn the volume down when j change the program / sequences and it’s driving me crazy

Is it possible you have MIDI enabled on those tracks and it’s sending a CC value out when it loads a new preset after switching sequences? I know it sends CC values for anything that’s parameter locked.

If that’s your issue you might want to consider changing the CC outs on the OP-Z to be CC 0, which disables CC out entirely.


Thank you! This is what I actually ended up doing and it resolved the problem :slight_smile:


This fixed my issue for hooking the op-z up with an mc101 as a sound module.

1 Like