OPlab midi out bug???--Found a work around----

Hi there, remember seeing in a thread somewhere about a bug confirmed by TE that is supposed to be fixed next update. Just want to confirm this is a bug when in mode “0” that midi is not sent to the midi out? Just trying to get midi from my OCTA to my OP-1 on channel 2 and to my Sub Phatty on channel thorough midi. Might be my programming, but remembered that bug.

hey Virt, hopefully TE releases a major Update for the Oplab and the OP-1 to get back on a Pro Level!

Just plug and Run. would be awesome.

…and are you still on NOORDEN? …you should play some shows in Cologne. :slight_smile:

You are correct @Virtual_Flannel, MIDI from In does not get transferred to Out. TE told me this would be fixed in the next update, and that was in f’ing December of 2013, and the last Oplab OS is from October of 2012… so take that how you will.

I don’t take it particularly well at all, but luckily for TE I don’t need to get MIDI from the In to the Out. And to their credit they did offer me a refund at the time, which I declined.

OpLab has so much potential. But as it is now it feels very limited, and somewhat clunky. At times I have it do exactly what I need it to do, other times it seems totally impossible to have it behave consistently. For example Mode 2 (USB Frenzy) continues to elude me… simply does not do what it is supposed to do, and I have no idea how to make it work in that mode…

Ok thanks for confirming guys, pretty wack! @JohnnyEgo I’m performing in Cologne on August …8th I think. It’s for a show called Noorden summer camp. Marx Trukker, jogging house, the whole crew will be there! Hope to see you there!

There is a website for that show now!


…true… think i have seen a poster or something…

. Gebäude 9 saved to be not a playground for stinky richkids. i will be there.
…maybe you can put me on your guest list. :wink:

Cool! PM your rln :slight_smile:

If the OP-1 is connected via USB to OP-Lab I take it that it can send midi clock, signal and CC’s to the midi OUT from the OP-Lab, yeah?

@spacetravelmadeeasy Yes! OP-1 works fine, it’s when using Midi in as your input that it does not route midi to the midi out.

Hey fam found an easy work around to this problem. Worked for my situation anyways. Maybe it’s obvious. I send Midi out from my Octa to my Moog Sub Phatty. Then send the Thru (or in this case the Out configured with midi merge) and send that to the OPlab. I then am controlling my iPad and OP-1 from the OPlab. Basically if the synth you want to control has a midi Thru, put that in the chain first then to the OPlab. Would be nice to do this, and still have the OPlabs midi out for another device. But you can always just daisy chain as long as you have a Thru on the device. Having a lot of fun working this way!


I'm glad I've found this topic. Spent good few days trying figure out why OT via Oplab's midi in is not sending any data to midi out and din sync. Seems that also cv/gate doesn't work. That's so pity as I bought Oplab mainly for syncing duties between OT and my modular synth plus all those extra features that made me think it's fantastic device.

So just to confirm... MIDI CV messages are also not being sent to CV/GATE outs on Oplab while using OT as an external sequencer... or there is something wrong I'm doing here?


hhmmm…i think this is a bug . maybe we will get an update these days! :wink:

my actual setup is like this and it works fine this way… casio dg-20 midi in/ op-1 usb host a/ macbook device port/machinedrum midi out/ and mono tribe CV/Gate.

i think the oplab operations change a bit if you plug more Instruments to it. sometimes it is sending CV/Gate from usb host a sometimes not. judge me if iam wrong.

i can tell you that if you have found your possible way it’s really tight and no fear of loosing any messages. :wink:

just in case—read the manual twice and more. it has a lot of information but it’s not as nice as the operator’s manual! :wink:

i was still a little overwhelmed after reading about different modes, put it together on the oplab and to see that it was a non-worker.

maybe mode 2 will solve your situation. read read read! :slight_smile:

try try try.

Thanks but yes I don’t have OP-1 anymore so non of the other modes will work in this setup I guess.

I am working hard on figuring out OpLab with my modular. It drives me crazy that there are some inconsistent behaviors there! The manual is shockingly minimal, given that the device is rather cryptic and potentially very complex in terms of functionality.
I use Op-1 and modular on a regular basis, so it seems that OpLab IS the piece that is specifically designed to connect the two, so I am really hoping that it gets a serious overhaul. Hopefully soon! :slight_smile:

I swear I can’t figure out what mode is what by the LEDs @piotr. I’ve tried reading them as binary left and right, and it never mades sense. I just turn the selector until shit starts working and leave it alone o.O

I wouldn’t hold your breath, the last update to the Oplab firmwae was 2012, and TE told me back in December of 2013 that a bug was being fixed “in the next update.”

@KrisM I know! But they continue to fan the OpLab flames with the cases and the new video demos… so am hoping that they didn’t just give up on the product! It clearly needs further work!