Repair your OPZ pop up encoder

Made a guide for people who have encoder pop out problem. Happened to me after few weeks of purchase. TE’s customer support are really bad. Here is how I fixed it myself.

Repair Guide


but then you took it down?

My Bad, I put the page on private. Fixed it now. Soon it should be available to view.

seems to work now. cheers

Just want to add a tip for anyone looking to diy-fix. Use Plumbers Tape wrapped around parts you want to sit tight. 100% non destructive repair.

1 Like

second that, DO NOT USE GLUE or anything that could be permanent. This is the state of my encoders rings. Ive had the popping up encoders problem and discovered the state of these yesterday. I wanna know whats really going on first before committing to an un-reversible fix. Yes, its still under warranty :slight_smile:

1 Like

but the grid around the bearings looks like some glue or plastic, right?

do they melt them into place?

i think if you scratch the OP-Z like yours they won‘t handle any warranty!?

like Breaking glued parts for any special purpose :sleeping:

What if you heat up the metal bearings allittle and while is kinda hot put the middle part back in and hold it in while it cools, that might be what they are doing, it looks like they cement the rings in afterwords.

The plumbers tape trick worked a friggin` treat, THANK YOU. £1.29 from amazon. FCKTE.

1 Like

I accedentally spilled some energydrink that splashed a bit on my op-z - luckily the only thing affected is the bearings that hold the encoders - and I’ve had luck getting 4 new bearings from the web, i just can get the old ones out, and im affrait to use force - how did you get yours out?

Have you tried washing the original bearings with isopropyl alcohol? Just try it first on a bit of the encoder colored part to make sure it is resistant.

Yeah, I’ve been trying to wash them a couple of times in different things: isopropyl alcohol, WD40, stuff like that, but with little to no effect - but i have some new bearing I could replace the old ones with, I just can’t get the old ones out - any suggestions at all?

I would heat them up with a hair dryer and gently apply force.

They seem to be glued, see the picture in this post: