The Definitive Guide to Trying to Connect Your OP-1 Via USB-MIDI


#81
Yes I set the OP1 to "SYNC" mode on the BPM page, but the strange thing is that there's no "EXT" message above the SYNC selection!? Is it because I'm using the beta OS??

I'm sure the MPC is sending midi clock message, I tried with my Tanzmaus and the sequencer is starting/stoping correctly with the correct tempo!?!?

Just to understand correctly – MPC as MIDI clock master does not work. If you swap Tanzmaus for MPC in the exact same setup, this works? Does the MPC send note messages fine to the OP-1 in this setup? Or no MIDI control at all?


#82

@GCF Yes I tried both way. OP1 as the master and MPC as the master.

Not sure I catch you right, you mean try to swap Tanzmaus with OP1? Yes I did it, with the exact same settings. The Tanzmaus starts and sync with the MPC while the OP1 doesn’t!?

@mixrasta are you on the beta os? On my side, I will try to downgrade to check if it syncs or not with the latest official one…

#83

Yes, I’m on the beta. Still haven’t checked the midimode, tho…


#84
@GCF Yes I tried both way. OP1 as the master and MPC as the master.
Not sure I catch you right, you mean try to swap Tanzmaus with OP1? Yes I did it, with the exact same settings. The Tanzmaus starts and sync with the MPC while the OP1 doesn't!?

Sorry, I think I misunderstood. You had success with MPC+Tanzmaus, not with OP1+Tanzmaus. Have you tried syncing your OP-1 with a DAW on the computer (as in, use Ableton Live to start/stop and sync the OP-1)? Because that might be telling of whether the best OS has this issue.


#85

I’ve been able to sync: MPC>>Tanzmaus, Tanzmaus>>MPC and I monitored their midi signal through an iconnectmidi and I have clock and transport messages.

With the OP1 I’ve been able finally to sync the OP1 as master >>Tanzmaus and MPC as slaves, but what I want is to slave the OP-1 to the MPC clock and transport commands!!

On the youtube video where the guy is syncing his Elektron A4 with his OP1, the Elektron is the master and an “EXT” message appears on the OP1 screen right above the “sync” selection and this is what I can’t get… It looks like the OP1 isn’t receiving or recognizing the clock and transport messages that the MPC or the Tanzmaus are sending…

(I do not have Ableton live, shame on me :wink:


#86

hi @Anyman59. did you find a solution for this issue?

i just got a Hobbytronic midi usb - din and i cannot get any sync to, and from the op-1… i can trigger notes and use any op-1 sequencer to play other synths, but can’t get sync to work in any direction.

#87

@Ayman59 @sno


Just to add to the Hobbytronic midi usb - din discussion. I’ve been trying to get OP1 to play nicely with the rest of my gear with similar results.

For me, with the Hobbytrinics unit:
- OP1 as a simple controller works great, also works well with all the sequencers
- with OP1 as master I can sync Novation Circuit and Roland TR-8 to tempo and start/stop
- can’t get OP1 to act as a slave (i.e. sync from Circuit or TR-8) - latest firmware crashes consistently when I try it

I’d like to keep using the Circuit for as the master so need to find a different solution (maybe the Kenton USB, I’d rather avoid laptop /iphone etc)

Cheers, Pal

#88

@Ayman59 @houtson


- I get no midi in with my Hobbytronic :confused: so op1 as slave is no good.
- op1 as a simple controller is ok here as well

and i can’t access the configuration settings (via terminal) to change the realtime messages setting to see if it helps…

i don’t recommend the Hobbytronic midi usb - din. oh, and their tech support is awful.


#89

Ahah got myself this HT MIDI USB convertor.
Indeed it’s hard to get reliable info.

To get the sync working one has to activate realtime messages, the support told me.
But so far I haven’t managed to do this.

Has anyone succeeded in activating sync on this little device ?


#90

In order to access the Hobbytronic Configuration settings use a terminal application. I use Serial (for mac). The USB serial port is called:

FT231X USB UART

Set the speed to 31250 Baud and leave all other settings to default: (Data Bits 8, Parity None, Stop Bits 1 and no flow control).

The screen is blank when connected, but type in ‘?’ and three options and their current status appear:

REALTIME (0=OFF, 1=ON)
FILTER (0=OFF, 1-16=ON)
HELP or ?

Hope this helps.

PS… I just ran a quick test…
iPad to Hobbytronics using a CCK & TE usb to midi (din) cable -> Midi in (din) on the Hobbytronic. OP-1 connected to Hobbytronic usb port. Fired up Midi Studio Pro in keyboard mode and the OP-1 responded to the ipad keyboard. In my case midi in via the Hobbytronics is working. REALTIME is ON on my HobbyTronics.<mytubeelement id=“myTubeRelayElementToPage” event=“preferencesUpdated” data="{“bundle”:{“label_delimitor”:":",“percentage”:"%",“smart_buffer”:“Smart Buffer”,“start_playing_when_buffered”:“Start playing when buffered”,“sound”:“Sound”,“desktop_notification”:“Desktop Notification”,“continuation_on_next_line”:"-",“loop”:“Loop”,“only_notify”:“Only Notify”,“estimated_time”:“Estimated Time”,“global_preferences”:“Global Preferences”,“no_notification_supported_on_your_browser”:“No notification style supported on your browser version”,“video_buffered”:“Video Buffered”,“buffered”:“Buffered”,“hyphen”:"-",“buffered_message”:“The video has been buffered as requested and is ready to play.”,“not_supported”:“Not Supported”,“on”:“On”,“off”:“Off”,“click_to_enable_for_this_site”:“Click to enable for this site”,“desktop_notification_denied”:“You have denied permission for desktop notification for this site”,“notification_status_delimitor”:";",“error”:“Error”,“adblock_interferance_message”:“Adblock (or similar extension) is known to interfere with SmartVideo. Please add this url to adblock whitelist.”,“calculating”:“Calculating”,“waiting”:“Waiting”,“will_start_buffering_when_initialized”:“Will start buffering when initialized”,“will_start_playing_when_initialized”:“Will start playing when initialized”,“completed”:“Completed”,“buffering_stalled”:“Buffering is stalled. Will stop.”,“stopped”:“Stopped”,“hr”:“Hr”,“min”:“Min”,“sec”:“Sec”,“any_moment”:“Any Moment”,“popup_donate_to”:“Donate to”,“extension_id”:null},“prefs”:{“desktopNotification”:true,“soundNotification”:true,“logLevel”:0,“enable”:true,“loop”:false,“hidePopup”:false,“autoPlay”:false,“autoBuffer”:false,“autoPlayOnBuffer”:false,“autoPlayOnBufferPercentage”:42,“autoPlayOnSmartBuffer”:true,“quality”:“default”,“fshd”:false,“onlyNotification”:false,“enableFullScreen”:true,“saveBandwidth”:false,“hideAnnotations”:false,“turnOffPagedBuffering”:false}}"><mytubeelement id=“myTubeRelayElementToTab” event=“relayPrefs” data="{“loadBundle”:true}">


#91

I get everything working except sync’ing clock/start and stop. Clock/start and stop are the realtime messages - I’ve tried configuring the unit with realtime set to on and off with no difference.

Works fine as a controller or being controlled by something else.

@stevey3d I don’t know studio pro but can you get the op1 to sync time (bpm) and start stop a sequence with the set up?

Thanks


#92

Hi Guys, I think this is the right thread to post in and see it’s active :slight_smile: I have a question that i hope is an easy one to answer.

I would like to connect OP-1 to an iPad running Auria Pro. I have the CCK and can control Auria via MIDI. But what i wanted to also do is record OP-1 audio out into Auria.

Is there a single interface you can recommend that would allow both MIDI in/out and Audio in to an iPad? There’s so many options, but I haven’t found one that would act as a USB host yet. But I’m sure I may have missed some options. Icing on the cake would be something that is bus powered for portable use.





#93

@houtson… I tried an arp directed to the OP-1 and varied the bpm. The OP-1 did not recognise the change in sync (though the notes played did change in tempo) in the Tempo screen. I used the same setup with an iConnectity Midi4+ and everything worked as expected… changing the arp BPM is reflected in the Tempo screen on the OP-1 and it also shows EXT. With the Hobbytronics neither of these worked. In my experience, at this current firmware revision (1.15), the Hobbytronics does not transmit sync successfully to the OP-1. I also experienced a number of OP-1 crashes that did not occur with the iConnect.
An alternative in this price bracket would be the Raspberry Pi. I purchased the Hobbytronics because I was having problems with my Pi but have managed to resolve those issues since. I connected up my Keystep to the Raspberry Pi and ran a sequence. The OP-1 recognises changes to the BPM and any sync change. It also shows EXT in the tempo window. A Rasberry Pi is a similar price to the Hobbytronics though does take some work up front to set it up.

Hope this helps<mytubeelement id=“myTubeRelayElementToPage” event=“preferencesUpdated” data="{“bundle”:{“label_delimitor”:":",“percentage”:"%",“smart_buffer”:“Smart Buffer”,“start_playing_when_buffered”:“Start playing when buffered”,“sound”:“Sound”,“desktop_notification”:“Desktop Notification”,“continuation_on_next_line”:"-",“loop”:“Loop”,“only_notify”:“Only Notify”,“estimated_time”:“Estimated Time”,“global_preferences”:“Global Preferences”,“no_notification_supported_on_your_browser”:“No notification style supported on your browser version”,“video_buffered”:“Video Buffered”,“buffered”:“Buffered”,“hyphen”:"-",“buffered_message”:“The video has been buffered as requested and is ready to play.”,“not_supported”:“Not Supported”,“on”:“On”,“off”:“Off”,“click_to_enable_for_this_site”:“Click to enable for this site”,“desktop_notification_denied”:“You have denied permission for desktop notification for this site”,“notification_status_delimitor”:";",“error”:“Error”,“adblock_interferance_message”:“Adblock (or similar extension) is known to interfere with SmartVideo. Please add this url to adblock whitelist.”,“calculating”:“Calculating”,“waiting”:“Waiting”,“will_start_buffering_when_initialized”:“Will start buffering when initialized”,“will_start_playing_when_initialized”:“Will start playing when initialized”,“completed”:“Completed”,“buffering_stalled”:“Buffering is stalled. Will stop.”,“stopped”:“Stopped”,“hr”:“Hr”,“min”:“Min”,“sec”:“Sec”,“any_moment”:“Any Moment”,“popup_donate_to”:“Donate to”,“extension_id”:null},“prefs”:{“desktopNotification”:true,“soundNotification”:true,“logLevel”:0,“enable”:true,“loop”:false,“hidePopup”:false,“autoPlay”:false,“autoBuffer”:false,“autoPlayOnBuffer”:false,“autoPlayOnBufferPercentage”:42,“autoPlayOnSmartBuffer”:true,“quality”:“default”,“fshd”:false,“onlyNotification”:false,“enableFullScreen”:true,“saveBandwidth”:false,“hideAnnotations”:false,“turnOffPagedBuffering”:false}}"><mytubeelement id=“myTubeRelayElementToTab” event=“relayPrefs” data="{“loadBundle”:true}">


#94

@stevey3d thanks for that, good to know I’m not doing anything wrong. I get exactly the same (crash when trying to sync). I’ve got a pi but was looking for something cheap, simple and plug n play. I’ll get in touch with hobbytronics and see if they want to fix it cheers, paul


#95

@Brian_Westfield The only one I know of (but I haven’t done any research on this either) is the iConnectAudio4. It has a USB Host connection required for OP-1 USB MIDI connection as well as 4 audio ins/outs. Not bus powered. And might be overkill for what you are trying to do. Others have mentioned USB hubs and such with iPhone, so maybe there is a separate audio in device that you could use at the same time. The Roland Portable Mixer just announced might fit this.


#96

@GCF Thank you, I’ll give it a look!


#97

Please note that the OP-1 does not do USB audio


#98

This little hobbytronics seems pretty nice !


#99

Same here with the Hobbytronics usb midi host. Midi out works fine, but midi in causes the op-1 to crash…


#100

What do you think about the new retrokits rk-004? Unfortunately not opto-isolated, but a lot of possibilities in a small and affordable tool…