Trying to update firmware, but clearly doing something obviously wrong

I’m just trying to update the firmware in my OP1.

Have connected it to the computer, held down the com key, and turned it on but… nothing happens.

Tried the same thing without connecting it to the computer, and nothing happens.

Clearly I’m missing something, what might that something be?

Is the OP charged?

I tried updating mine, then when switching it on, some upside-down mirrored characters came up on screen. I tried doing a factory reset COM +7 at startup, the characters on screen were still mirrored, and it restarted to show the screen image shifted halfway down, so I could only see the top half of the screen, and it no longer shows up as a USB disk. At least it worked a bit, but when switching off and on again, it didn’t come on.

Something strange going on here. Anything else I can try? Another factory reset? Any other suggestions?

I’m also having trouble updating to the latest firmware version. I’ve tried to do the update using both my Mac and PC laptops. Everything seems fine until I get to the step where the OP-1 disk image has to be ejected. The ejection is fine in each case but then pressing the ‘com’ button does absolutely nothing.

I’ve even performed a factory reset and tried updating again. No luck.

Any suggestions?

Maybe try download the file again…

I’ve had the same issue. Everything works fine but I can’t load up the TE-Boot screen so I can’t format or update or anything.

I’ve been emailing back and forth with TE but it’s getting frustrating as they keep asking for more details and I’ve already sent them videos and pictures.


Yes, it is charged. Does it need to be 100% charged before uploading?

Same thing happened to me.

Right… Time to email Teenage Engineering then.

Eject didn’t work?

Which OS version was installed before?

I upgraded successfully from 14203 to 216 beta, but I did “Format Drive” before that (which now has disappeared from the boot menu). And then from 216 to 218.

I have been chatting to them over email but because it’s the weekend I haven’t had a reply for a while. I’m sure they will kick back off on Monday.

Important aspect: USB-connection.

Just posting in the case that this could help someone…

I updated my firmware successfully, but I made a mistake at first…

So, I plugged in my OP-1, started it when holding COM, selected ‘update firmware’ and followed the instructions… but I made ONE MISTAKE! And that was to unplug my USB cable from the computer after I powered down my op-1… I misinterpreted the instruction that said “Eject or press COM button…” (It is a second “eject” instruction, AFTER ejecting it from my laptop…) and I unplugged the cable after powering it off. Then, when I restarted it, I got a bunch of numbers on my screen and the op-1 wouldn’t do anything, like it was locked-up or something… Unplugging the cable seemed to be the mistake.

So, I tried “turning it off and on again” and repeating the entire firmware update. Then, when the op-1 told me to power it down and turn it on again, I kept the USB cord plugged in the second time, and it worked just fine.

The second “eject” instruction… the one that says “eject or press COM” seems to be pointless, since the OP-1 tells you to power down and no eject or com-pushing is necessary.

Hope that helps someone.

Just to clarify, I did eject my op-1 from my laptop, but I never unplugged the cable… this seemed to fix the problem I was having updating the firmware.

I updated from 076 to the newest version today (factory reset) and cannot save samples… does anyone know what to do?

Important aspect: USB-connection.

still same issue.

I've had the same issue. Everything works fine but I can't load up the TE-Boot screen so I can't format or update or anything.

I've been emailing back and forth with TE but it's getting frustrating as they keep asking for more details and I've already sent them videos and pictures.

Hi, I’m having the same problem here, I can’t access TE-Boot screen, when I hold COM while powering up the OP-1 nothing happens. I contacted TE and they asked me some info as well as sending them a video showing the problem, then they stopped replying. I waited, because this happened on friday, but today is wednesday and they still have not replied.

My OP-1 was misbehaving so much trying to update it, but since I just bought it, I used Amazon’s no-hassle return service and got a new one which I am happy to say updated without a hitch. I first did a factory reset, followed by an update, and it was both fast and successful.

As long as the OP-1 behaves with the new firmware, I will be quite happy. I have used it two minutes after updating, and already loving the new soundset, even if it does seem strange to leave out so many of the sounds that people have used before and got used to that were part of the original firmware. The arpeggiator is fun, and I can already hear it’s less likely to pop when looping. It’s all good.

Hi guys, I’m new here, have my op1 like 2 weeks and have same problem - wanted to update it and bootloader doesn’t work - anyone has new info on that case? I saw custom firmware topic here - is it possible to bootload op1 from pc? Cheers!