Well I'm Sad

Update for the Op-1 Comes out finally and for some reason my OP-1 COM button works fine, but opening the boot menu… Holding com and powering on . I hear the click but the screen just stays black :frowning:

Sad indeed: https://op-forums.com/t/op-1-will-not-load-boot-screen/13614/5

1 Like

Please share your progress with us!

2 Likes

directions from TE!
THIS FIX DID NOT WORK FOR ME
BUT THIS IS WHAT THEY CLAIM THE FIX IS, GIVE IT A SHOT I SUPPOSE?

how to fix the “no te-boot” issue:

  1. start OP-1
  2. connect usb
  3. enter disk mode: [shift] + [com], [T3]
  4. recommended: backup the files from OP-1 to your computer.
  5. drag and drop “te-boot-fix.op1” onto OP-1 removable drive
  6. eject OP-1
  7. restart OP-1
  8. allow update and then turn off OP-1
  9. hold [com] and start OP-1
  10. update with latest official firmware as usual
  11. enjoy.

hope this works for you. thank you for your patience.

kindly,
teenage engineering support

Attachment(s)
te-boot-fix.op1

4 Likes

Hello there!

If somebody is still having this issue. I was so sad about it as well. Also tried this te-boot-fix.op1 - no effect!
BUT JUST RANDOMLY found a solution:

“te-boot-fix.op1” - I RENAMED it to just “teboot.op1” (without “-”). Actually i even copy it multiply times with “boot.op1” and “teboot.op1” - and it worked. So you can play with the name and possible it will work.

Afterwards everything like in the instruction above =) Hope that helps.

2 Likes

Thanks! I’ve had this issue for multiple years and this still did not fix teboot.

Curious what steps you took after placing the teboot.op1 file. I try eject, and then turning off the OP-1, removing the USB cable and starting the OP-1. This just boots the OP1 to the standard UI without doing an update.

appreciate any additional details!

I’m trying this but am stuck at step 8. It says allow it to update, but I’m not sure what that means? Is it supposed to happen automatically, or is there a confirmation page I’m missing?

Here’s what worked for me:

  1. Powered on OP-1
  2. Connected OP-1 to computer via USB
  3. Entered disk mode on OP-1
  4. Copied the file from this thread onto OP-1, but renamed it to “te-boot.op1”
  5. Hit the “1” key on OP-1
  6. OP-1 screen went black and presented “Found firmware” message
  7. Let OP-1 do its thing until told to power off
  8. Powered off OP-1
  9. Powered on the OP-1 normally to make sure it wasn’t bricked and in case it needed to finish any process
  10. Powered off the OP-1
  11. Held COM and powered on the OP-1 – te-boot worked successfully

Important: Step 4 or 5 might have been the magic step – I had tried renaming the file to some of the other suggestions here and had been using the “Eject device” option in Windows. “Hard” switching out of disk mode and/or using “te-boot.op1” as the filename seemed to do the trick.

Firmware version: 00241

Hope this helps someone else out there.

2 Likes