Connecting op-1 to iPhone to manage samples?

So you can access the file structure from the iPhone that way?

With the iPad it worked. Never tried with the iPhone but I don’t see why it would not work.

Really appreciate your response but as far as I know the iPad and iPhone don’t have the UI to access the files structure of the op-1.

Once connected in disk mode on the op-1 what do you open on your iPad to see the files?

1 Like

they changed this a couple years ago (in i think iOS12?)
u can access the files via disk mode ipad iphone now
i believe u just use the built in files app?

Yes indeed. From the iPhone I can even access to usb keys content.

I’ve brought an office apple lightening to USB adapter. I switch to disk mode on the OP-1 and then plug in the cable. The cable that joins the op-1 to the laptop on the op-1 lcd flashes green BUT the device does not show on the iPhone.

I have tried a different iPhone, restarting the iPhone while connected and sorts of combinations. What the hell am I missing here?

1 Like

I have tested my iPad pro and OP-1/OP-Z. both OP-1 and OP-Z could be mounted on the iPad Files app.

Thanks Ryan. Not the case on either iPhone unfortunately. I have a iPad but it’s USB C and I don’t have the correct adapter for that.

Has anyone else got it working on an iPhone?

I can confirm.
On my iPad Pro the connection works with no problem. Files app shows the OP-1 as a disk.(NO NAME)
On my iPhone Files app does not show OP-1 at all.

Same thing in both devices with the OP1 Manager app.

So it’s not me.

Thanks for letting me know. :saluting_face:

wonder if its drawing (or thinks its drawing) too much power on the iphone
but not w/ the ipad // ipad pro ?

Makes sense.

yea thats def it
just tested it w/ my iphone
if u use the CCK that has the extra charge port
and plug that into a power source
it shows up in the FILES app like it should
didn’t matter if i had USB CHARGING turned OFF or ON

Hey mate, what version of the OP1 Firmware are you using? Is it 243?

yes 243

not sure if order of operations matters
but i plugged everything in before turning on the OP1
OP1 to phone w/ CCK
CCK charge port to USB power plug
then i turned the OP1 on
then i went into disk mode

took a beat to sync up
but then on the OP1 screen the lil computer was blinking a lil square
and the cable started flashing green and i was g2g

without the charging port plugged in
the lil square would show up
but the cable never flashed green

I’ll try that again with a better cable and a 1st party apple charger when I get home from work, thanks!

Checked with Apple’s Camera Connection Kit, with and without power cable connected on iPhone.

Without power: Files nor OP1 Manager app DOES NOT show OP1 as a disk on iPhone.

With power: Files and OP1 Manager app SHOW OP1 as a disk on iPhone. If then you unplug the power cord, it un mounts the unit the second you do it.

So, it can be done. Matter of power.


Thanks everyone.

Have ordered an adapter with the extra power slot.

Correct. Tried with a sufficient charger and it worked.

Recommend the 20 watt USB -C charger as it charged my iphone SE 3rd gen and my OP-1 at the same time.

As I posted the original question, I wanted to update the post with my outcome.

I started with an official lightening to usb apple adapter but as pointed out in this thread, although it works on an iPads, iPhones need additional power. Apple do a second adapter that has lightening at one end with usb and an additional lightening at the other to supply additional power.

I searched for the cheapest unbranded Powered adapter I could find and with the use of an additional lightening cable I too was able to access my Op-1 on my iPhone.

Thanks again to everyone that contributed!