OP-Z wont power on without cable

i hadnt turned my op-z on for a while and went to update the firmware today. that worked well. however, the unit wont power on unless i have it connected to a battery or the computer. i tried resetting the factory settings, taking the battery out for a while, different cables, nothing. the battery meter is full solid green and the ios app shows 100%.

any ideas? could the battery just be defective? not sure what else to try. it works totally normally when plugged in.

Did you perhaps by accident disable charging via USB? Hold “screen” and press E2 (should be the rightmost keyboard-key) to (de-)activate that feature.
Perhaps that’s why your OP-Z only works while cable-powered, but the battery won’t be loaded.

Befor you ask: this feature can be useful to get rid of ground noise while recording etc.

If that doesn’t work -> factory rest :-/

I am having the same issue as original poster. Even a hard reset not doing the trick -> full battery when plugged in. Won’t turn when unplugged. Do I need a new battery?

Try taking the battery out a while, then put back in.

Took me a few tries to figure it out. It wasnt the battery itself. It was the op-z still reading a full charge on the battery when it was actually at zero. I ended up powering it via USB and (re)enabled USB charging. Not sure why/how that option changed, but that fixed it.

1 Like

I’m experiencing the same exact issue with my op-z. It says the battery has 100% charge but does not work without powering it by USB (so in reality its 0%, I guess). Changing the usb charging enable/disable state doesn’t work, it immediately crashes the device because there’s no power anymore then. So I suppose it’s enabled right now and I can’t disable it. And taking the battery out for some time and putting it back also didn’t work.

Does anyone have advice or specific steps I should follow?

Earlier today I received my new op-z and it’s having that exact issue. I’ve tried charging it with different chargers, computers and the battery never charges but still says that it is a 100% full. I’ve updated the firmware, run a factory reset, removed the battery for some time, tried enable/disabling the USB charging (screen+E2) and nothing makes any difference. The battery states as 100% full but as soon as it is unplugged it stops working.
If I can’t fix it I’ll return it tomorrow and ask for a replacement.

None of the three I have experienced this issue. I’d return it unless you want to try loading up older firmware than updating to the newest version. Make sure to eject the Z before unplugging it to complete firmware to sample loading procedures.

Darn it, I’ve got the same problem. Trying to charge it with USB now after disabling/enabling USB charging via the button shortcut (as I can’t edit the text file since that requires you to start the device in content mode which is impossible when the battery’s dead). Factory reset didn’t help either.

I’ll contact TE tomorrow if the problem withstands. Have any of you guys reached out to them yet?

I’ve returned the first one and got a second one for a different vendor. This one works as expected.

I’ve sent an inquiry to the vendor to have my unit fixed or replaced, they’re awaing a response from TE. Hope it won’t take too long. But I’ve got the OP-1 to keep me busy in the meanwhile.

1 Like

it worked for me!!!
thank you very much! :love_you_gesture:

just a little explanation.
my op-z rested for some months unused (I bought a used one on ebay) and the battery apparently was dead.
I just took a 5v transformer and linked it to the battery poles for 15 seconds, like a_lex said.
After that I put the battery on the op-z and everything was fine.


I sent mine back and I’ll receive a new unit from TE next week. The tips here didn’t work for me and I had some other issues too, but thanks for the advice though.

A friend of mine recently borrowed me his unit while I’m waiting for mine and I must say: damn how I’ve missed this little machine in the short few weeks I’ve been without it. I freakin’ love this device and I’m so happy to get a functioning unit again. This is literally one of my absolute favourite things in life!

So I have been dealing with this the next two hours and solved it this way.

I updated the firmware that the op-z came with.

Basically I connected it to my computer, downloaded the latest firmware, and where it says instructions.txt, just followed the steps there and after that the battery and charging indicator worked perfectly.

Maybe try if you don’t follow lucifer this new one might keep working?? Worth a shot…

I got mine new and it didn’t turn on without the power cable, the battery was full (according to the display).
I took out the battery, powered it on. Held screen + e2 (right side E key).
Turn it off
Put the battery back
And plugged in the cable.
Now it is charging.

1 Like

Same issue here.

Displaying full battery charge but wouldn’t power up on battery. Fine on usb power.

I updated the firmware which then showed the battery was empty.

Left it on usb power which blinked yellow, trying to wake the battery. After 4 hours on usb blinking yellow it switched to green and can power up without usb.

Hope that helps.

EDIT: after charging overnight it never got to full charge which seemed wrong. I then followed the below instructions and that seems to have fixed it.

after having this issue crop up again and again, i ended up replacing the battery (the original one). no issues since then.